]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/tools/git/mantisbt.nix
Use attrs for secrets instead of lists
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / git / mantisbt.nix
CommitLineData
da30ae4f 1{ env, mantisbt_2, mantisbt_2-plugins, config }:
43dac87f 2rec {
4288c2f2
IB
3 activationScript = {
4 deps = [ "httpd" ];
5 text = ''
6 install -m 0755 -o ${apache.user} -g ${apache.group} -d /var/lib/php/sessions/mantisbt
7 '';
8 };
4c4652aa 9 keys."webapps/tools-mantisbt" = {
43dac87f
IB
10 user = apache.user;
11 group = apache.group;
12 permissions = "0400";
13 text = ''
14 <?php
15 $g_hostname = '${env.postgresql.socket}';
16 $g_db_username = '${env.postgresql.user}';
17 $g_db_password = '${env.postgresql.password}';
18 $g_database_name = '${env.postgresql.database}';
19 $g_db_type = 'pgsql';
20 $g_crypto_master_salt = '${env.master_salt}';
21 $g_allow_signup = OFF;
22 $g_allow_anonymous_login = ON;
23 $g_anonymous_account = 'anonymous';
24
25 $g_phpMailer_method = PHPMAILER_METHOD_SENDMAIL;
26 $g_smtp_host = 'localhost';
27 $g_smtp_username = ''';
28 $g_smtp_password = ''';
29 $g_webmaster_email = 'mantisbt@tools.immae.eu';
30 $g_from_email = 'mantisbt@tools.immae.eu';
31 $g_return_path_email = 'mantisbt@tools.immae.eu';
32 $g_from_name = 'Mantis Bug Tracker at git.immae.eu';
619e4f46 33 $g_email_receive_own = ON;
43dac87f
IB
34 # --- LDAP ---
35 $g_login_method = LDAP;
36 $g_ldap_protocol_version = 3;
ab8f306d
IB
37 $g_ldap_server = 'ldaps://${env.ldap.host}:636';
38 $g_ldap_root_dn = 'ou=users,${env.ldap.base}';
39 $g_ldap_bind_dn = '${env.ldap.dn}';
43dac87f
IB
40 $g_ldap_bind_passwd = '${env.ldap.password}';
41 $g_use_ldap_email = ON;
42 $g_use_ldap_realname = ON;
43 $g_ldap_uid_field = 'uid';
44 $g_ldap_realname_field = 'cn';
ab8f306d 45 $g_ldap_organization = '${env.ldap.filter}';
43dac87f 46 '';
4c4652aa 47 };
da30ae4f 48 webRoot = (mantisbt_2.override { mantis_config = config.secrets.fullPaths."webapps/tools-mantisbt"; }).withPlugins (p: [p.slack p.source-integration]);
43dac87f
IB
49 apache = rec {
50 user = "wwwrun";
51 group = "wwwrun";
52 modules = [ "proxy_fcgi" ];
53 webappName = "tools_mantisbt";
54 root = "/run/current-system/webapps/${webappName}";
5400b9b6 55 vhostConf = socket: ''
43dac87f
IB
56 Alias /mantisbt "${root}"
57 <Directory "${root}">
58 DirectoryIndex index.php
59 <FilesMatch "\.php$">
5400b9b6 60 SetHandler "proxy:unix:${socket}|fcgi://localhost"
43dac87f
IB
61 </FilesMatch>
62
63 AllowOverride All
05a3b252 64 SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
43dac87f
IB
65 Options FollowSymlinks
66 Require all granted
67 </Directory>
68 <Directory "${root}/admin">
69 #Reenable during upgrade
70 Require all denied
71 </Directory>
72 '';
73 };
74 phpFpm = rec {
75 serviceDeps = [ "postgresql.service" "openldap.service" ];
76 basedir = builtins.concatStringsSep ":" (
da30ae4f 77 [ webRoot config.secrets.fullPaths."webapps/tools-mantisbt" ]
43dac87f 78 ++ webRoot.plugins);
5400b9b6
IB
79 pool = {
80 "listen.owner" = apache.user;
81 "listen.group" = apache.group;
82 "pm" = "ondemand";
83 "pm.max_children" = "60";
84 "pm.process_idle_timeout" = "60";
43dac87f 85
5400b9b6 86 "php_admin_value[upload_max_filesize]" = "5000000";
43dac87f 87
5400b9b6
IB
88 "php_admin_value[open_basedir]" = "${basedir}:/tmp:/var/lib/php/sessions/mantisbt";
89 "php_admin_value[session.save_path]" = "/var/lib/php/sessions/mantisbt";
90 };
43dac87f
IB
91 };
92}