]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/tools/cloud/default.nix
Upgrade nixos-unstable
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / cloud / default.nix
CommitLineData
ab8f306d 1{ lib, pkgs, config, ... }:
10889174 2let
65b715d7
IB
3 nextcloud = pkgs.webapps.nextcloud.withApps (a: [
4 a.apporder a.audioplayer a.bookmarks a.calendar a.carnet a.contacts
5 a.cookbook a.deck a.extract a.files_markdown a.files_readmemd
6 a.flowupload a.gpxedit a.gpxpod a.keeweb a.maps a.metadata a.music
7 a.notes a.ocsms a.passman a.polls a.spreed a.tasks
8 ]);
ab8f306d 9 env = config.myEnv.tools.nextcloud;
0ede7366
IB
10 varDir = "/var/lib/nextcloud";
11 webappName = "tools_nextcloud";
12 apacheRoot = "/run/current-system/webapps/${webappName}";
4288c2f2 13 cfg = config.myServices.websites.tools.cloud;
0ede7366 14 phpFpm = rec {
65b715d7 15 basedir = builtins.concatStringsSep ":" ([ nextcloud varDir ] ++ nextcloud.apps);
5400b9b6
IB
16 pool = {
17 "listen.owner" = "wwwrun";
18 "listen.group" = "wwwrun";
19 "pm" = "ondemand";
20 "pm.max_children" = "60";
21 "pm.process_idle_timeout" = "60";
0ede7366 22
5400b9b6
IB
23 "php_admin_value[output_buffering]" = "0";
24 "php_admin_value[max_execution_time]" = "1800";
25 "php_admin_value[zend_extension]" = "opcache";
26 #already enabled by default?
27 #"php_value[opcache.enable]" = "1";
28 "php_value[opcache.enable_cli]" = "1";
29 "php_value[opcache.interned_strings_buffer]" = "8";
30 "php_value[opcache.max_accelerated_files]" = "10000";
31 "php_value[opcache.memory_consumption]" = "128";
32 "php_value[opcache.save_comments]" = "1";
33 "php_value[opcache.revalidate_freq]" = "1";
34 "php_admin_value[memory_limit]" = "512M";
10889174 35
5400b9b6
IB
36 "php_admin_value[open_basedir]" = "/run/wrappers/bin/sendmail:${basedir}:/proc/meminfo:/dev/urandom:/proc/self/fd:/tmp";
37 "php_admin_value[session.save_path]" = "${varDir}/phpSessions";
38 };
0ede7366 39 };
10889174 40in {
4288c2f2 41 options.myServices.websites.tools.cloud = {
10889174
IB
42 enable = lib.mkEnableOption "enable cloud website";
43 };
44
45 config = lib.mkIf cfg.enable {
d880826a 46 # FIXME: find a way to backup the data
29f8cb85 47 services.websites.env.tools.modules = [ "proxy_fcgi" ];
10889174 48
29f8cb85 49 services.websites.env.tools.vhostConfs.cloud = {
10889174 50 certName = "eldiron";
7df420c2 51 addToCerts = true;
10889174 52 hosts = ["cloud.immae.eu" ];
0ede7366 53 root = apacheRoot;
10889174 54 extraConfig = [
0ede7366
IB
55 ''
56 SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
57 <Directory ${apacheRoot}>
58 AcceptPathInfo On
59 DirectoryIndex index.php
60 Options FollowSymlinks
61 Require all granted
62 AllowOverride all
63
64 <IfModule mod_headers.c>
65 Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains; preload"
66 </IfModule>
67 <FilesMatch "\.php$">
68 CGIPassAuth on
5400b9b6 69 SetHandler "proxy:unix:${config.services.phpfpm.pools.nextcloud.socket}|fcgi://localhost"
0ede7366
IB
70 </FilesMatch>
71
72 </Directory>
73 ''
10889174
IB
74 ];
75 };
76
1a718805 77 secrets.keys = [{
0ede7366
IB
78 dest = "webapps/tools-nextcloud";
79 user = "wwwrun";
80 group = "wwwrun";
81 permissions = "0600";
c4216ddb 82 # This file is not actually included, see activationScript below
0ede7366
IB
83 text = ''
84 <?php
c4216ddb 85 include('${nextcloud}/version.php');
0ede7366
IB
86 $CONFIG = array (
87 // FIXME: change this value when nextcloud starts getting slow
88 'instanceid' => '${env.instance_id}1',
89 'datadirectory' => '/var/lib/nextcloud/',
90 'passwordsalt' => '${env.password_salt}',
91 'debug' => false,
92 'dbtype' => 'pgsql',
c4216ddb 93 'version' => implode($OC_Version, '.'),
0ede7366
IB
94 'dbname' => '${env.postgresql.database}',
95 'dbhost' => '${env.postgresql.socket}',
96 'dbtableprefix' => 'oc_',
97 'dbuser' => '${env.postgresql.user}',
98 'dbpassword' => '${env.postgresql.password}',
99 'installed' => true,
100 'maxZipInputSize' => 0,
101 'allowZipDownload' => true,
102 'forcessl' => true,
103 'theme' => ${"''"},
104 'maintenance' => false,
105 'trusted_domains' =>
106 array (
107 0 => 'cloud.immae.eu',
108 ),
109 'secret' => '${env.secret}',
110 'appstoreenabled' => false,
111 'appstore.experimental.enabled' => true,
112 'loglevel' => 2,
113 'trashbin_retention_obligation' => 'auto',
114 'htaccess.RewriteBase' => '/',
115 'mail_smtpmode' => 'sendmail',
116 'mail_smtphost' => '127.0.0.1',
117 'mail_smtpname' => ''',
118 'mail_smtppassword' => ''',
119 'mail_from_address' => 'nextcloud',
120 'mail_smtpauth' => false,
121 'mail_domain' => 'tools.immae.eu',
122 'memcache.local' => '\\OC\\Memcache\\APCu',
123 'memcache.locking' => '\\OC\\Memcache\\Redis',
124 'filelocking.enabled' => true,
125 'redis' =>
126 array (
127 'host' => '${env.redis.socket}',
128 'port' => 0,
ab8f306d 129 'dbindex' => ${env.redis.db},
0ede7366
IB
130 ),
131 'overwrite.cli.url' => 'https://cloud.immae.eu',
132 'ldapIgnoreNamingRules' => false,
133 'ldapProviderFactory' => '\\OCA\\User_LDAP\\LDAPProviderFactory',
3a1461cf 134 'has_rebuilt_cache' => true,
0ede7366
IB
135 );
136 '';
137 }];
5ccc61bb 138 users.users.root.packages = let
10889174
IB
139 occ = pkgs.writeScriptBin "nextcloud-occ" ''
140 #! ${pkgs.stdenv.shell}
0ede7366
IB
141 cd ${nextcloud}
142 NEXTCLOUD_CONFIG_DIR="${nextcloud}/config" \
10889174 143 exec \
c4216ddb
IB
144 sudo -u wwwrun ${pkgs.php74}/bin/php \
145 -c ${pkgs.php74}/etc/php.ini \
10889174
IB
146 occ $*
147 '';
148 in [ occ ];
149
0ede7366 150 system.activationScripts.nextcloud = {
3a1461cf
IB
151 deps = [ "secrets" ];
152 text = let
153 confs = lib.attrsets.mapAttrs (n: v: pkgs.writeText "${n}.json" (builtins.toJSON v)) nextcloud.otherConfig;
154 in
155 ''
0ede7366
IB
156 install -m 0755 -o wwwrun -g wwwrun -d ${varDir}
157 install -m 0750 -o wwwrun -g wwwrun -d ${varDir}/phpSessions
3a1461cf
IB
158 ${builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList (n: v:
159 "install -D -m 0644 -o wwwrun -g wwwrun -T ${v} ${varDir}/config/${n}.json"
160 ) confs)}
c4216ddb 161 #install -D -m 0600 -o wwwrun -g wwwrun -T /var/secrets/webapps/tools-nextcloud ${varDir}/config/config.php
0ede7366
IB
162 '';
163 };
3a1461cf 164 # FIXME: add a warning when config.php changes
a95ab089
IB
165 system.extraSystemBuilderCmds = ''
166 mkdir -p $out/webapps
0ede7366 167 ln -s ${nextcloud} $out/webapps/${webappName}
a95ab089 168 '';
10889174 169
f40f5b23 170 services.phpfpm.pools.nextcloud = {
5400b9b6
IB
171 user = "wwwrun";
172 group = "wwwrun";
173 settings = phpFpm.pool;
2053ddac 174 phpPackage = pkgs.php74.withExtensions({ enabled, all }: enabled ++ [ all.redis all.apcu all.opcache ]);
10889174
IB
175 };
176
9c35092c
IB
177 services.cron = {
178 enable = true;
c418f62a
IB
179 systemCronJobs = let
180 script = pkgs.writeScriptBin "nextcloud-cron" ''
181 #! ${pkgs.stdenv.shell}
182 export LOCALE_ARCHIVE=/run/current-system/sw/lib/locale/locale-archive
183 export PATH=/run/wrappers/bin:$PATH
c4216ddb 184 ${pkgs.php74}/bin/php -d memory_limit=512M -f ${nextcloud}/cron.php
c418f62a
IB
185 '';
186 in [
9c35092c 187 ''
c418f62a 188 */15 * * * * wwwrun ${script}/bin/nextcloud-cron
9c35092c
IB
189 ''
190 ];
191 };
10889174
IB
192 };
193}