]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/papa/maison_bbc.nix
Remove webappdirs
[perso/Immae/Config/Nix.git] / modules / private / websites / papa / maison_bbc.nix
CommitLineData
8b2f048b 1{ lib, config, ... }:
9a414bd6
IB
2let
3 cfg = config.myServices.websites.papa.maison_bbc;
9a414bd6
IB
4in {
5 options.myServices.websites.papa.maison_bbc.enable = lib.mkEnableOption "enable Papa Maison bbc website";
6
7 config = lib.mkIf cfg.enable {
9a414bd6 8 services.webstats.sites = [ { name = "maison.bbc.bouya.org"; } ];
9a414bd6 9
9a414bd6
IB
10 services.websites.env.production.vhostConfs.papa_maison_bbc = {
11 certName = "papa";
12 addToCerts = true;
13 hosts = [ "maison.bbc.bouya.org" ];
750fe5a4 14 root = ./maison_bbc_static;
9a414bd6
IB
15 extraConfig = [
16 ''
8b2f048b 17 ErrorDocument 404 /index.html
750fe5a4 18 <Directory ${./maison_bbc_static}>
8b2f048b 19 DirectoryIndex index.htm index.html
9a414bd6
IB
20 AllowOverride None
21 Require all granted
9a414bd6
IB
22 </Directory>
23 ''
24 ];
25 };
26 };
27}
28