]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/isabelle/spip_builder.nix
Upgrade nixos
[perso/Immae/Config/Nix.git] / modules / private / websites / isabelle / spip_builder.nix
CommitLineData
423c3f1c
IB
1{ apacheUser, apacheGroup, iridologie, config }:
2rec {
3 app = iridologie.override { inherit (config) environment; };
4 phpFpm = rec {
5 serviceDeps = [ "mysql.service" ];
5400b9b6
IB
6 pool = {
7 "listen.owner" = "${apacheUser}";
8 "listen.group" = "${apacheGroup}";
9 "php_admin_value[upload_max_filesize]" = "20M";
10 "php_admin_value[post_max_size]" = "20M";
11 #"php_admin_flag[log_errors]" = "on";
12 "php_admin_value[open_basedir]" = "${app.spipConfig}:${configDir}:${app}:${app.varDir}:/tmp";
13 "php_admin_value[session.save_path]" = "${app.varDir}/phpSessions";
14 } // (if app.environment == "dev" then {
15 "pm" = "ondemand";
16 "pm.max_children" = "5";
17 "pm.process_idle_timeout" = "60";
18 } else {
19 "pm" = "dynamic";
20 "pm.max_children" = "20";
21 "pm.start_servers" = "2";
22 "pm.min_spare_servers" = "1";
23 "pm.max_spare_servers" = "3";
24 });
423c3f1c
IB
25 };
26 keys = [{
27 dest = "webapps/${app.environment}-iridologie";
28 user = apacheUser;
29 group = apacheGroup;
30 permissions = "0400";
31 text = ''
32 SetEnv SPIP_CONFIG_DIR "${configDir}"
33 SetEnv SPIP_VAR_DIR "${app.varDir}"
34 SetEnv SPIP_SITE "iridologie-${app.environment}"
35 SetEnv SPIP_LDAP_BASE "dc=immae,dc=eu"
36 SetEnv SPIP_LDAP_HOST "ldaps://ldap.immae.eu"
37 SetEnv SPIP_LDAP_SEARCH_DN "${config.ldap.dn}"
38 SetEnv SPIP_LDAP_SEARCH_PW "${config.ldap.password}"
39 SetEnv SPIP_LDAP_SEARCH "${config.ldap.filter}"
40 SetEnv SPIP_MYSQL_HOST "${config.mysql.host}"
41 SetEnv SPIP_MYSQL_PORT "${config.mysql.port}"
42 SetEnv SPIP_MYSQL_DB "${config.mysql.database}"
43 SetEnv SPIP_MYSQL_USER "${config.mysql.user}"
44 SetEnv SPIP_MYSQL_PASSWORD "${config.mysql.password}"
45 '';
46 }];
47 apache = rec {
48 modules = [ "proxy_fcgi" ];
49 webappName = "iridologie_${app.environment}";
50 root = "/run/current-system/webapps/${webappName}";
5400b9b6 51 vhostConf = socket: ''
423c3f1c
IB
52 Include /var/secrets/webapps/${app.environment}-iridologie
53
54 RewriteEngine On
55
56 <FilesMatch "\.php$">
5400b9b6 57 SetHandler "proxy:unix:${socket}|fcgi://localhost"
423c3f1c
IB
58 </FilesMatch>
59
60 <Directory ${root}>
61 DirectoryIndex index.php index.htm index.html
62 Options -Indexes +FollowSymLinks +MultiViews +Includes
63 Include ${root}/htaccess.txt
64
65 AllowOverride AuthConfig FileInfo Limit
66 Require all granted
67 </Directory>
68
69 <DirectoryMatch "${root}/squelettes">
70 Require all denied
71 </DirectoryMatch>
72
73 <FilesMatch "(.htaccess|rewrite-rules|.gitignore)$">
74 Require all denied
75 </FilesMatch>
76
77 ${if app.environment == "dev" then ''
78 <Location />
79 Use LDAPConnect
80 Require ldap-group cn=isabelle.immae.eu,cn=httpd,ou=services,dc=immae,dc=eu
81 ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://iridologie.icommandeur.org\"></html>"
82 </Location>
83 '' else ''
84 Use Stats iridologie.icommandeur.org
85 ''}
86 '';
87 };
88 activationScript = {
89 deps = [ "wrappers" ];
90 text = ''
91 install -m 0755 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir} ${app.varDir}/IMG ${app.varDir}/tmp ${app.varDir}/local
92 install -m 0750 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir}/phpSessions
93 '';
94 };
95 configDir = ./config;
96}