]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/isabelle/aten_integration.nix
Upgrade nixos
[perso/Immae/Config/Nix.git] / modules / private / websites / isabelle / aten_integration.nix
CommitLineData
ab8f306d 1{ lib, pkgs, config, ... }:
f8026b6e 2let
829ef7f1 3 secrets = config.myEnv.websites.isabelle.aten_integration;
717ccfd9 4 app = pkgs.webapps.aten.override { environment = secrets.environment; };
829ef7f1 5 cfg = config.myServices.websites.isabelle.aten_integration;
717ccfd9 6 pcfg = config.services.phpApplication;
f8026b6e 7in {
829ef7f1 8 options.myServices.websites.isabelle.aten_integration.enable = lib.mkEnableOption "enable Aten's website in integration";
f8026b6e
IB
9
10 config = lib.mkIf cfg.enable {
d2e703c5 11 services.duplyBackup.profiles.aten_dev.rootDir = app.varDir;
717ccfd9 12 services.phpApplication.apps.aten_dev = {
2e48907d
IB
13 websiteEnv = "integration";
14 httpdUser = config.services.httpd.Inte.user;
15 httpdGroup = config.services.httpd.Inte.group;
717ccfd9
IB
16 httpdWatchFiles = [
17 config.secrets.fullPaths."webapps/${app.environment}-aten"
18 ];
2e48907d
IB
19 inherit (app) webRoot varDir;
20 inherit app;
21 serviceDeps = [ "postgresql.service" ];
22 preStartActions = [
23 "APP_ENV=${app.environment} ./bin/console --env=${app.environment} cache:clear --no-warmup"
24 ];
717ccfd9 25 phpOpenbasedir = [ "/tmp" ];
5400b9b6
IB
26 phpPool = {
27 "php_admin_value[upload_max_filesize]" = "20M";
28 "php_admin_value[post_max_size]" = "20M";
29 #"php_admin_flag[log_errors]" = "on";
30 "pm" = "ondemand";
31 "pm.max_children" = "5";
32 "pm.process_idle_timeout" = "60";
33 };
34 phpEnv = {
35 SYMFONY_DEBUG_MODE = "yes";
36 };
2e48907d
IB
37 };
38
717ccfd9
IB
39 secrets.keys = [{
40 dest = "webapps/${app.environment}-aten";
41 user = config.services.httpd.Inte.user;
9f66adf4 42 group = config.services.httpd.Inte.group;
717ccfd9 43 permissions = "0400";
ab8f306d
IB
44 text = let
45 # cf:
46 # https://secure.php.net/manual/fr/function.parse-url.php
47 # vendor/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php#parseDatabaseUrlQuery
48 psql_url = with secrets.postgresql; "pdo-pgsql://${user}:${password}@invalid:${port}/${database}?host=${socket}";
49 in ''
717ccfd9
IB
50 SetEnv APP_ENV "${app.environment}"
51 SetEnv APP_SECRET "${secrets.secret}"
ab8f306d 52 SetEnv DATABASE_URL "${psql_url}"
717ccfd9
IB
53 '';
54 }];
55 services.websites.env.integration.vhostConfs.aten_dev = {
0f71cd76 56 certName = "integration";
f8026b6e
IB
57 addToCerts = true;
58 hosts = [ "dev.aten.pro" ];
717ccfd9
IB
59 root = pcfg.webappDirs.aten_dev;
60 extraConfig = [
61 ''
62 <FilesMatch "\.php$">
63 SetHandler "proxy:unix:${pcfg.phpListenPaths.aten_dev}|fcgi://localhost"
64 </FilesMatch>
65
66 Include ${config.secrets.fullPaths."webapps/${app.environment}-aten"}
67
68 <Location />
69 Use LDAPConnect
70 Require ldap-group cn=dev.aten.pro,cn=httpd,ou=services,dc=immae,dc=eu
71 ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://aten.pro\"></html>"
72 </Location>
73
74 <Location /backend>
75 Use LDAPConnect
76 Require ldap-group cn=dev.aten.pro,cn=httpd,ou=services,dc=immae,dc=eu
77 ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://aten.pro\"></html>"
78 </Location>
79
80 <Directory ${pcfg.webappDirs.aten_dev}>
81 Options Indexes FollowSymLinks MultiViews Includes
82 AllowOverride All
83 Require all granted
84 DirectoryIndex index.php
85 FallbackResource /index.php
86 </Directory>
87 ''
88 ];
f8026b6e
IB
89 };
90 };
91}