]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/immae/temp.nix
Remove attachment header for temp.immae.eu
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / temp.nix
CommitLineData
ab8f306d 1{ lib, pkgs, config, ... }:
ce493c5d 2let
f8026b6e
IB
3 cfg = config.myServices.websites.immae.temp;
4 varDir = "/var/lib/ftp/temp.immae.eu";
ab8f306d 5 env = config.myEnv.websites.temp;
ce493c5d 6in {
f8026b6e 7 options.myServices.websites.immae.temp.enable = lib.mkEnableOption "enable Temp' website";
ce493c5d 8
f8026b6e 9 config = lib.mkIf cfg.enable {
29f8cb85
IB
10 services.websites.env.production.modules = [ "headers" ];
11 services.websites.env.production.vhostConfs.temp = {
ce493c5d 12 certName = "eldiron";
7df420c2 13 addToCerts = true;
ce493c5d
IB
14 hosts = [ "temp.immae.eu" ];
15 root = varDir;
16 extraConfig = [
17 ''
7da3ceec 18 Use Apaxy "${varDir}" "title .duplicity-ignore"
ce493c5d
IB
19 <Directory "${varDir}">
20 Options -Indexes
21 AllowOverride None
22 Require all granted
23 </Directory>
24
25 <DirectoryMatch "${varDir}/(.+)">
26 Options Indexes
27 </DirectoryMatch>
28 ''
29 ];
30 };
31 };
32}
33