]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/immae/production.nix
Add normalesup website to CI
[perso/Immae/Config/Nix.git] / modules / private / websites / immae / production.nix
CommitLineData
8a964143 1{ lib, pkgs, config, myconfig, ... }:
f759f52e 2let
f8026b6e 3 cfg = config.myServices.websites.immae.production;
8fa7ff2c 4 varDir = "/var/lib/buildbot/outputs/immaeEu";
f8026b6e 5 env = myconfig.env.websites.immae;
f759f52e 6in {
f8026b6e 7 options.myServices.websites.immae.production.enable = lib.mkEnableOption "enable Immae's website";
f759f52e 8
f8026b6e 9 config = lib.mkIf cfg.enable {
9eae2b47 10 services.webstats.sites = [ { name = "www.immae.eu"; } ];
f759f52e 11
29f8cb85 12 services.websites.env.production.vhostConfs.immae = {
f759f52e 13 certName = "eldiron";
7df420c2 14 addToCerts = true;
f759f52e
IB
15 hosts = [ "www.immae.eu" ];
16 root = varDir;
17 extraConfig = [
18 ''
19 Use Stats www.immae.eu
20
f759f52e
IB
21 <Directory ${varDir}>
22 DirectoryIndex index.php index.htm index.html
23 Options Indexes FollowSymLinks MultiViews Includes
24 AllowOverride All
25 Require all granted
26 </Directory>
f759f52e
IB
27 ''
28 ];
29 };
70606070 30
29f8cb85 31 services.websites.env.production.vhostConfs.bouya = {
70606070 32 certName = "eldiron";
7df420c2 33 addToCerts = true;
70606070
IB
34 hosts = [ "bouya.org" "www.bouya.org" ];
35 root = null;
36 extraConfig = [ ''
37 RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://www.normalesup.org/~bouya/
38 '' ];
39 };
f759f52e
IB
40 };
41}