]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/florian/builder_app.nix
Move personal websites to modules
[perso/Immae/Config/Nix.git] / modules / private / websites / florian / builder_app.nix
CommitLineData
f8026b6e 1{ apacheUser, apacheGroup, tellesflorian, config }:
c890321d
IB
2rec {
3 app = tellesflorian.override { inherit (config) environment; };
4 keys = [
5 {
6 dest = "webapps/${app.environment}-tellesflorian-passwords";
f8026b6e
IB
7 user = apacheUser;
8 group = apacheGroup;
c890321d
IB
9 permissions = "0400";
10 text = ''
11 invite:${config.invite_passwords}
12 '';
13 }
14 {
15 dest = "webapps/${app.environment}-tellesflorian";
f8026b6e
IB
16 user = apacheUser;
17 group = apacheGroup;
c890321d
IB
18 permissions = "0400";
19 text = ''
20 # This file is auto-generated during the composer install
21 parameters:
22 database_host: ${config.mysql.host}
23 database_port: ${config.mysql.port}
24 database_name: ${config.mysql.name}
25 database_user: ${config.mysql.user}
26 database_password: ${config.mysql.password}
27 mailer_transport: smtp
28 mailer_host: 127.0.0.1
29 mailer_user: null
30 mailer_password: null
31 secret: ${config.secret}
32 '';
33 }
34 ];
35 phpFpm = rec {
36 preStart = ''
37 if [ ! -f "${app.varDir}/currentWebappDir" -o \
38 ! -f "${app.varDir}/currentKey" -o \
39 "${app}" != "$(cat ${app.varDir}/currentWebappDir 2>/dev/null)" ] \
40 || ! sha512sum -c --status ${app.varDir}/currentKey; then
41 pushd ${app} > /dev/null
42 /run/wrappers/bin/sudo -u wwwrun ./bin/console --env=${app.environment} cache:clear --no-warmup
43 popd > /dev/null
44 echo -n "${app}" > ${app.varDir}/currentWebappDir
45 sha512sum /var/secrets/webapps/${app.environment}-tellesflorian > ${app.varDir}/currentKey
46 fi
47 '';
48 serviceDeps = [ "mysql.service" ];
49 socket = "/var/run/phpfpm/floriantelles-${app.environment}.sock";
50 pool = ''
51 listen = ${socket}
f8026b6e
IB
52 user = ${apacheUser}
53 group = ${apacheGroup}
54 listen.owner = ${apacheUser}
55 listen.group = ${apacheGroup}
c890321d
IB
56 php_admin_value[upload_max_filesize] = 20M
57 php_admin_value[post_max_size] = 20M
58 ;php_admin_flag[log_errors] = on
59 php_admin_value[open_basedir] = "/var/secrets/webapps/${app.environment}-tellesflorian:${app}:${app.varDir}:/tmp"
60 php_admin_value[session.save_path] = "${app.varDir}/phpSessions"
61 ${if app.environment == "dev" then ''
62 pm = ondemand
63 pm.max_children = 5
64 pm.process_idle_timeout = 60
65 env[SYMFONY_DEBUG_MODE] = "yes"
66 '' else ''
67 pm = dynamic
68 pm.max_children = 20
69 pm.start_servers = 2
70 pm.min_spare_servers = 1
71 pm.max_spare_servers = 3
72 ''}'';
73 };
74 apache = rec {
c890321d
IB
75 modules = [ "proxy_fcgi" ];
76 webappName = "florian_${app.environment}";
77 root = "/run/current-system/webapps/${webappName}";
78 vhostConf = ''
79 <FilesMatch "\.php$">
80 SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"
81 </FilesMatch>
2f0f1c48 82
c890321d
IB
83 ${if app.environment == "dev" then ''
84 <Location />
85 AuthBasicProvider file ldap
86 Use LDAPConnect
87 Require ldap-group cn=app.tellesflorian.com,cn=httpd,ou=services,dc=immae,dc=eu
2f0f1c48 88
c890321d
IB
89 AuthUserFile "/var/secrets/webapps/${app.environment}-tellesflorian-passwords"
90 Require user "invite"
2f0f1c48 91
c890321d
IB
92 ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://tellesflorian.com\"></html>"
93 </Location>
2f0f1c48 94
c890321d
IB
95 <Directory ${root}>
96 Options Indexes FollowSymLinks MultiViews Includes
97 AllowOverride None
98 Require all granted
2f0f1c48 99
c890321d 100 DirectoryIndex app_dev.php
2f0f1c48 101
c890321d
IB
102 <IfModule mod_negotiation.c>
103 Options -MultiViews
104 </IfModule>
2f0f1c48 105
c890321d
IB
106 <IfModule mod_rewrite.c>
107 RewriteEngine On
2f0f1c48 108
c890321d
IB
109 RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
110 RewriteRule ^(.*) - [E=BASE:%1]
2f0f1c48 111
c890321d
IB
112 # Maintenance script
113 RewriteCond %{DOCUMENT_ROOT}/maintenance.php -f
114 RewriteCond %{SCRIPT_FILENAME} !maintenance.php
115 RewriteRule ^.*$ %{ENV:BASE}/maintenance.php [R=503,L]
116 ErrorDocument 503 /maintenance.php
2f0f1c48 117
c890321d
IB
118 # Sets the HTTP_AUTHORIZATION header removed by Apache
119 RewriteCond %{HTTP:Authorization} .
120 RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
2f0f1c48 121
c890321d
IB
122 RewriteCond %{ENV:REDIRECT_STATUS} ^$
123 RewriteRule ^app_dev\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]
2f0f1c48 124
c890321d
IB
125 # If the requested filename exists, simply serve it.
126 # We only want to let Apache serve files and not directories.
127 RewriteCond %{REQUEST_FILENAME} -f
128 RewriteRule ^ - [L]
2f0f1c48 129
c890321d
IB
130 # Rewrite all other queries to the front controller.
131 RewriteRule ^ %{ENV:BASE}/app_dev.php [L]
132 </IfModule>
2f0f1c48 133
c890321d
IB
134 </Directory>
135 '' else ''
136 <Directory ${root}>
137 Options Indexes FollowSymLinks MultiViews Includes
138 AllowOverride All
139 Require all granted
140 </Directory>
141 ''}
142 '';
143 };
144 activationScript = {
145 deps = [ "wrappers" ];
146 text = ''
f8026b6e 147 install -m 0755 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir} \
c890321d 148 ${app.varDir}/var
f8026b6e 149 install -m 0750 -o ${apacheUser} -g ${apacheGroup} -d ${app.varDir}/phpSessions
c890321d 150 '';
2f0f1c48 151 };
c890321d 152}