]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/denise/aventuriers.nix
Make some adjustments for Denise aventuriers page
[perso/Immae/Config/Nix.git] / modules / private / websites / denise / aventuriers.nix
CommitLineData
f989f3ed
IB
1{ lib, config, pkgs, ... }:
2let
3 cfg = config.myServices.websites.denise.aventuriers;
4 varDir = "/var/lib/buildbot/outputs/denise/aventuriers";
5in {
6 options.myServices.websites.denise.aventuriers.enable = lib.mkEnableOption "enable Denise's Aventuriers website";
7
8 config = lib.mkIf cfg.enable {
9 services.websites.env.production.vhostConfs.denise_aventuriers = {
10 certName = "denise";
11 addToCerts = true;
12 hosts = [ "aventuriers.syanni.eu" ];
13 root = varDir;
14 extraConfig = [
15 ''
16 <Directory ${varDir}>
31ed973b 17 DirectoryIndex aventuriers.html
f989f3ed
IB
18 Options Indexes FollowSymLinks MultiViews Includes
19 AllowOverride None
20 Require all granted
21 </Directory>
22 ''
23 ];
24 };
25 };
26}