]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/connexionswing/production.nix
Use attrs for secrets instead of lists
[perso/Immae/Config/Nix.git] / modules / private / websites / connexionswing / production.nix
CommitLineData
ab8f306d 1{ lib, pkgs, config, ... }:
f8026b6e 2let
ab8f306d 3 secrets = config.myEnv.websites.connexionswing.production;
d3452fc5 4 app = pkgs.callPackage ./app {
dcac3ec7 5 composerEnv = pkgs.composerEnv.override { php = pkgs.php72; };
d3452fc5
IB
6 environment = secrets.environment;
7 varDir = "/var/lib/connexionswing_production";
8 secretsPath = config.secrets.fullPaths."websites/connexionswing/production";
9 };
f8026b6e 10 cfg = config.myServices.websites.connexionswing.production;
8164ed90 11 pcfg = config.services.phpApplication;
f8026b6e
IB
12in {
13 options.myServices.websites.connexionswing.production.enable = lib.mkEnableOption "enable Connexionswing's website in production";
14
15 config = lib.mkIf cfg.enable {
aeb9dd1e 16 services.duplyBackup.profiles.connexionswing_production.rootDir = app.varDir;
5a61f6ad 17 services.duplyBackup.profiles.connexionswing_production.remotes = ["eriomem" "ovh"];
f8026b6e 18 services.webstats.sites = [ { name = "connexionswing.com"; } ];
d3452fc5 19 services.phpApplication.apps.connexionswing_production = {
8164ed90
IB
20 websiteEnv = "production";
21 httpdUser = config.services.httpd.Prod.user;
22 httpdGroup = config.services.httpd.Prod.group;
23 inherit (app) webRoot varDir;
24 varDirPaths = {
25 "medias" = "0700";
26 "uploads" = "0700";
27 "var" = "0700";
28 };
29 inherit app;
30 serviceDeps = [ "mysql.service" ];
31 preStartActions = [
32 "./bin/console --env=${app.environment} cache:clear --no-warmup"
33 ];
34 phpOpenbasedir = [ "/tmp" "/run/wrappers/bin/sendmail" ];
5400b9b6
IB
35 phpPool = {
36 "php_admin_value[upload_max_filesize]" = "20M";
37 "php_admin_value[post_max_size]" = "20M";
38 #"php_admin_flag[log_errors]" = "on";
39 "pm" = "dynamic";
40 "pm.max_children" = "20";
41 "pm.start_servers" = "2";
42 "pm.min_spare_servers" = "1";
43 "pm.max_spare_servers" = "3";
44 };
8164ed90 45 phpWatchFiles = [
d3452fc5 46 config.secrets.fullPaths."websites/connexionswing/production"
8164ed90 47 ];
dcac3ec7 48 phpPackage = pkgs.php72;
f40f5b23 49 };
8164ed90 50
4c4652aa
IB
51 secrets.keys."websites/connexionswing/production" = {
52 user = config.services.httpd.Prod.user;
53 group = config.services.httpd.Prod.group;
54 permissions = "0400";
55 text = ''
56 # This file is auto-generated during the composer install
57 parameters:
58 database_host: ${secrets.mysql.host}
59 database_port: ${secrets.mysql.port}
60 database_name: ${secrets.mysql.database}
61 database_user: ${secrets.mysql.user}
62 database_password: ${secrets.mysql.password}
63 database_server_version: ${pkgs.mariadb.mysqlVersion}
64 mailer_transport: sendmail
65 mailer_host: null
66 mailer_user: null
67 mailer_password: null
68 subscription_email: ${secrets.email}
69 allow_robots: true
70 secret: ${secrets.secret}
71 services:
72 swiftmailer.mailer.default.transport:
73 class: Swift_SendmailTransport
74 arguments: ['/run/wrappers/bin/sendmail -bs']
75 '';
76 };
8164ed90 77
d3452fc5 78 services.websites.env.production.vhostConfs.connexionswing_production = {
f8026b6e
IB
79 certName = "connexionswing";
80 certMainHost = "connexionswing.com";
81 hosts = ["connexionswing.com" "sandetludo.com" "www.connexionswing.com" "www.sandetludo.com" ];
d3452fc5 82 root = pcfg.webappDirs.connexionswing_production;
8164ed90
IB
83 extraConfig = [
84 ''
85 <FilesMatch "\.php$">
d3452fc5 86 SetHandler "proxy:unix:${pcfg.phpListenPaths.connexionswing_production}|fcgi://localhost"
8164ed90
IB
87 </FilesMatch>
88
89 <Directory ${app.varDir}/medias>
90 Options FollowSymLinks
91 AllowOverride None
92 Require all granted
93 </Directory>
94
95 <Directory ${app.varDir}/uploads>
96 Options FollowSymLinks
97 AllowOverride None
98 Require all granted
99 </Directory>
100
101 Use Stats connexionswing.com
102
d3452fc5 103 <Directory ${pcfg.webappDirs.connexionswing_production}>
8164ed90
IB
104 Options Indexes FollowSymLinks MultiViews Includes
105 AllowOverride All
106 Require all granted
107 </Directory>
108 ''
109 ];
17f6eae9 110 };
f8026b6e
IB
111 };
112}