]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/chloe/app/default.nix
Migrate mylibs to niv (work in progress)
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / app / default.nix
CommitLineData
7667c367
IB
1{ environment ? "prod"
2, varDir ? "/var/lib/chloe_${environment}"
db343436 3, spip, stdenv, sassc, sources }:
7667c367 4let
db343436
IB
5 siteDir = stdenv.mkDerivation {
6 version = sources.websites-chloe-app.version;
7 pname = "chloe";
8 src = sources.websites-chloe-app;
7667c367
IB
9 buildPhase = ''
10 make
11 '';
12 installPhase = ''
13 cp -a . $out
14 '';
15 buildInputs = [ sassc ];
db343436 16 };
7667c367
IB
17in
18spip.override {
19 ldap = true;
20 siteName = "chloe";
d3452fc5 21 inherit environment siteDir varDir;
7667c367 22}