]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/websites/chloe/app/default.nix
Refactor websites
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / app / default.nix
CommitLineData
7667c367
IB
1{ environment ? "prod"
2, varDir ? "/var/lib/chloe_${environment}"
3, spip, stdenv, mylibs, sassc }:
4let
5 siteDir = stdenv.mkDerivation (mylibs.fetchedGitPrivate ./chloe.json // rec {
6 buildPhase = ''
7 make
8 '';
9 installPhase = ''
10 cp -a . $out
11 '';
12 buildInputs = [ sassc ];
13 });
14in
15spip.override {
16 ldap = true;
17 siteName = "chloe";
d3452fc5 18 inherit environment siteDir varDir;
7667c367 19}