]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/system/backup-2.nix
Remove mail command in backup script
[perso/Immae/Config/Nix.git] / modules / private / system / backup-2.nix
CommitLineData
8415083e 1{ privateFiles }:
619e4f46 2{ config, pkgs, resources, ... }:
8415083e
IB
3{
4 boot.kernelPackages = pkgs.linuxPackages_latest;
ab8f306d 5 myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
ab8f306d 6
8415083e
IB
7 imports = builtins.attrValues (import ../..);
8
9 deployment = {
10 targetEnv = "hetznerCloud";
11 hetznerCloud = {
ab8f306d 12 authToken = config.myEnv.hetznerCloud.authToken;
8415083e
IB
13 datacenter = "hel1-dc2";
14 location ="hel1";
15 serverType = "cx11";
16 };
17 };
18
ae485806
IB
19 fileSystems = {
20 "/backup2" = {
21 fsType = "ext4";
22 device = "UUID=b9425333-f567-435d-94d8-b26c22d93426";
23 };
24 };
25
26 networking = {
27 firewall.enable = true;
28 interfaces."ens3".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
29 (n: ips: { address = ips.ip4; prefixLength = 32; })
619e4f46 30 (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.hostEnv.ips);
ae485806
IB
31 interfaces."ens3".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
32 (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
619e4f46 33 config.hostEnv.ips);
dc0e644a 34 defaultGateway6 = { address = "fe80::1"; interface = "ens3"; };
285380fe
IB
35 };
36
619e4f46
IB
37 myServices.certificates.enable = true;
38 services.nginx = {
39 enable = true;
40 recommendedOptimisation = true;
41 recommendedGzipSettings = true;
42 recommendedProxySettings = true;
43 };
44 networking.firewall.allowedTCPPorts = [ 80 443 ];
45
4227853a
IB
46 services.cron = {
47 mailto = "cron@immae.eu";
48 enable = true;
49 };
50
285380fe
IB
51 services.rsyncBackup = {
52 mountpoint = "/backup2";
ab8f306d
IB
53 profiles = config.myEnv.rsync_backup.profiles;
54 ssh_key_public = config.myEnv.rsync_backup.ssh_key.public;
55 ssh_key_private = config.myEnv.rsync_backup.ssh_key.private;
ae485806
IB
56 };
57
deca5e9b 58 myServices.mailRelay.enable = true;
619e4f46 59 myServices.mailBackup.enable = true;
9f202523 60 myServices.monitoring.enable = true;
ec9b6564
IB
61 myServices.databasesReplication = {
62 postgresql = {
63 enable = true;
64 base = "/backup2";
65 hosts = {
66 eldiron = {
67 slot = "backup_2";
619e4f46 68 connection = "postgresql://backup-2:${config.hostEnv.ldap.password}@eldiron.immae.eu";
ec9b6564
IB
69 };
70 };
71 };
9f6a7862
IB
72 mariadb = {
73 enable = true;
74 base = "/backup2";
75 hosts = {
76 eldiron = {
77 serverId = 2;
78 # mysql resolves "backup-2" host and checks the ip, but uses /etc/hosts which only contains ip4
ab8f306d 79 host = config.myEnv.servers.eldiron.ips.main.ip4;
9f6a7862
IB
80 port = "3306";
81 user = "backup-2";
619e4f46 82 password = config.hostEnv.ldap.password;
9f6a7862 83 dumpUser = "root";
ab8f306d 84 dumpPassword = config.myEnv.databases.mysql.systemUsers.root;
9f6a7862
IB
85 };
86 };
87 };
dded6699
IB
88 redis = {
89 enable = true;
90 base = "/backup2";
91 hosts = {
92 eldiron = {
93 host = "127.0.0.1";
94 port = "16379";
95 };
96 };
97 };
16b80abd
IB
98 openldap = {
99 enable = true;
100 base = "/backup2";
101 hosts = {
102 eldiron = {
ab8f306d
IB
103 url = "ldaps://${config.myEnv.ldap.host}:636";
104 dn = config.myEnv.ldap.replication_dn;
105 password = config.myEnv.ldap.replication_pw;
106 base = config.myEnv.ldap.base;
16b80abd
IB
107 };
108 };
109 };
ec9b6564
IB
110 };
111
8415083e
IB
112 # This value determines the NixOS release with which your system is
113 # to be compatible, in order to avoid breaking some software such as
114 # database servers. You should change this only after NixOS release
115 # notes say you should.
116 # https://nixos.org/nixos/manual/release-notes.html
117 system.stateVersion = "19.03"; # Did you read the comment?
118}