]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/system/backup-2.nix
Use attrs for secrets instead of lists
[perso/Immae/Config/Nix.git] / modules / private / system / backup-2.nix
CommitLineData
258dd18b 1{ config, pkgs, resources, name, ... }:
8415083e 2{
34abd6af
IB
3 deployment = {
4 targetUser = "root";
5 targetHost = config.hostEnv.ips.main.ip4;
6 substituteOnDestination = true;
7 };
282c67a1
IB
8 # ssh-keyscan backup-2 | nix-shell -p ssh-to-age --run ssh-to-age
9 secrets.ageKeys = [ "age1kk3nr27qu42j28mcfdag5lhq0zu2pky7gfanvne8l4z2ctevjpgskmw0sr" ];
4c4652aa
IB
10 secrets.keys = {
11 "rsync_backup/identity" = {
bd5c5d4e
IB
12 user = "backup";
13 group = "backup";
14 permissions = "0400";
15 text = config.myEnv.rsync_backup.ssh_key.private;
4c4652aa
IB
16 };
17 "rsync_backup/identity.pub" = {
bd5c5d4e
IB
18 user = "backup";
19 group = "backup";
20 permissions = "0444";
21 text = config.myEnv.rsync_backup.ssh_key.public;
4c4652aa
IB
22 };
23 };
8415083e 24 boot.kernelPackages = pkgs.linuxPackages_latest;
282c67a1 25 myEnv = import ../../../nixops/secrets/environment.nix;
ab8f306d 26
34abd6af 27 imports = [ <nixpkgs/nixos/modules/profiles/qemu-guest.nix> ] ++ builtins.attrValues (import ../..);
8415083e 28
ae485806
IB
29 fileSystems = {
30 "/backup2" = {
31 fsType = "ext4";
32 device = "UUID=b9425333-f567-435d-94d8-b26c22d93426";
33 };
34abd6af 34 "/" = { device = "/dev/sda1"; fsType = "ext4"; };
ae485806
IB
35 };
36
37 networking = {
38 firewall.enable = true;
39 interfaces."ens3".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
40 (n: ips: { address = ips.ip4; prefixLength = 32; })
619e4f46 41 (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.hostEnv.ips);
ae485806
IB
42 interfaces."ens3".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
43 (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
619e4f46 44 config.hostEnv.ips);
dc0e644a 45 defaultGateway6 = { address = "fe80::1"; interface = "ens3"; };
285380fe
IB
46 };
47
34abd6af
IB
48 boot.loader.grub.device = "nodev";
49
619e4f46 50 myServices.certificates.enable = true;
258dd18b
IB
51 security.acme.certs."${name}" = {
52 user = config.services.nginx.user;
53 group = config.services.nginx.group;
54 };
619e4f46
IB
55 services.nginx = {
56 enable = true;
57 recommendedOptimisation = true;
58 recommendedGzipSettings = true;
59 recommendedProxySettings = true;
60 };
61 networking.firewall.allowedTCPPorts = [ 80 443 ];
62
4227853a
IB
63 services.cron = {
64 mailto = "cron@immae.eu";
65 enable = true;
66 };
67
285380fe
IB
68 services.rsyncBackup = {
69 mountpoint = "/backup2";
ab8f306d 70 profiles = config.myEnv.rsync_backup.profiles;
bd5c5d4e
IB
71 ssh_key_public = config.secrets.fullPaths."rsync_backup/identity.pub";
72 ssh_key_private = config.secrets.fullPaths."rsync_backup/identity";
ae485806
IB
73 };
74
deca5e9b 75 myServices.mailRelay.enable = true;
619e4f46 76 myServices.mailBackup.enable = true;
9f202523 77 myServices.monitoring.enable = true;
ec9b6564
IB
78 myServices.databasesReplication = {
79 postgresql = {
80 enable = true;
81 base = "/backup2";
9f16e659 82 mainPackage = pkgs.postgresql;
ec9b6564
IB
83 hosts = {
84 eldiron = {
85 slot = "backup_2";
619e4f46 86 connection = "postgresql://backup-2:${config.hostEnv.ldap.password}@eldiron.immae.eu";
9f16e659 87 package = pkgs.postgresql;
ec9b6564
IB
88 };
89 };
90 };
9f6a7862
IB
91 mariadb = {
92 enable = true;
93 base = "/backup2";
94 hosts = {
95 eldiron = {
96 serverId = 2;
97 # mysql resolves "backup-2" host and checks the ip, but uses /etc/hosts which only contains ip4
ab8f306d 98 host = config.myEnv.servers.eldiron.ips.main.ip4;
9f6a7862
IB
99 port = "3306";
100 user = "backup-2";
619e4f46 101 password = config.hostEnv.ldap.password;
9f6a7862 102 dumpUser = "root";
ab8f306d 103 dumpPassword = config.myEnv.databases.mysql.systemUsers.root;
9f6a7862
IB
104 };
105 };
106 };
dded6699
IB
107 redis = {
108 enable = true;
109 base = "/backup2";
110 hosts = {
111 eldiron = {
112 host = "127.0.0.1";
113 port = "16379";
114 };
115 };
116 };
16b80abd
IB
117 openldap = {
118 enable = true;
119 base = "/backup2";
120 hosts = {
121 eldiron = {
ab8f306d
IB
122 url = "ldaps://${config.myEnv.ldap.host}:636";
123 dn = config.myEnv.ldap.replication_dn;
124 password = config.myEnv.ldap.replication_pw;
125 base = config.myEnv.ldap.base;
16b80abd
IB
126 };
127 };
128 };
ec9b6564
IB
129 };
130
8415083e
IB
131 # This value determines the NixOS release with which your system is
132 # to be compatible, in order to avoid breaking some software such as
133 # database servers. You should change this only after NixOS release
134 # notes say you should.
135 # https://nixos.org/nixos/manual/release-notes.html
d43e0c61 136 system.stateVersion = "20.03"; # Did you read the comment?
8415083e 137}