]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/monitoring/objects_eban.nix
Adjustments for monitoring
[perso/Immae/Config/Nix.git] / modules / private / monitoring / objects_eban.nix
CommitLineData
2edbb2d8
IB
1{ ... }:
2let
3 serviceTemplate = rest: {
4 host_name = "eban.bzh";
5 use = "external-web-service";
6 contacts = "eban";
7 contact_groups = "null";
8 check_interval = "15";
9
10 servicegroups = "webstatus-resources";
c41d0de8 11 _webstatus_namespace = "eban";
2edbb2d8
IB
12 } // rest;
13in
14{
15 contact = {
16 eban = {
17 use = "generic-contact";
18 host_notification_commands = "notify-host-eban-url";
19 service_notification_commands = "notify-service-eban-url";
20 };
21 };
22 host = {
23 "eban.bzh" = {
24 alias = "eban.bzh";
25 address = "eban.bzh";
26 use = "linux-server";
27 hostgroups = "webstatus-hosts";
28 contacts = "eban";
29 contact_groups = "null";
30 _webstatus_name = "Eban";
31 _webstatus_vhost = "status.eban.bzh";
c41d0de8 32 _webstatus_namespace = "eban";
2edbb2d8
IB
33 };
34 };
35 service = [
36 (serviceTemplate {
37 service_description = "Eban website is up and running";
38 check_command = ["check_https" "eban.bzh" "/" "<title>"];
39 _webstatus_name = "Main Website";
40 _webstatus_url = "https://eban.bzh/";
41 })
42 (serviceTemplate {
43 service_description = "Eban blog is up and running";
44 check_command = ["check_https" "blog.eban.bzh" "/" "<title>"];
45 _webstatus_name = "Blog";
46 _webstatus_url = "https://blog.eban.bzh/";
47 })
48 (serviceTemplate {
49 service_description = "Eban gitea is up and running";
50 check_command = ["check_https" "git.eban.bzh" "/" "<title>"];
51 _webstatus_name = "Git";
52 _webstatus_url = "https://git.eban.bzh/";
53 })
54 (serviceTemplate {
c41d0de8
IB
55 service_description = "Eban Bitwarden is up and running";
56 check_command = ["check_https" "bitwarden.eban.bzh" "/" "<title"];
2edbb2d8 57
c41d0de8
IB
58 _webstatus_name = "Bitwarden";
59 _webstatus_url = "https://bitwarden.eban.bzh/";
2edbb2d8
IB
60 })
61 ];
62}