]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/mail/postfix.nix
Add e-mail checks monitoring
[perso/Immae/Config/Nix.git] / modules / private / mail / postfix.nix
CommitLineData
71a2425e 1{ lib, pkgs, config, nodes, ... }:
a929614f 2{
8415083e 3 config = lib.mkIf config.myServices.mail.enable {
d2e703c5 4 services.duplyBackup.profiles.mail.excludeFile = ''
8415083e
IB
5 + /var/lib/postfix
6 '';
7 secrets.keys = [
8 {
9 dest = "postfix/mysql_alias_maps";
10 user = config.services.postfix.user;
11 group = config.services.postfix.group;
12 permissions = "0440";
13 text = ''
14 # We need to specify that option to trigger ssl connection
15 tls_ciphers = TLSv1.2
ab8f306d
IB
16 user = ${config.myEnv.mail.postfix.mysql.user}
17 password = ${config.myEnv.mail.postfix.mysql.password}
18 hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
19 dbname = ${config.myEnv.mail.postfix.mysql.database}
8415083e
IB
20 query = SELECT DISTINCT destination
21 FROM forwardings_merge
22 WHERE
23 ((regex = 1 AND '%s' REGEXP CONCAT('^',source,'$') ) OR (regex = 0 AND source = '%s'))
24 AND active = 1
25 AND '%s' NOT IN
26 (
27 SELECT source
28 FROM forwardings_blacklisted
29 WHERE source = '%s'
30 ) UNION
31 SELECT 'devnull@immae.eu'
a929614f
IB
32 FROM forwardings_blacklisted
33 WHERE source = '%s'
8415083e
IB
34 '';
35 }
36 {
37 dest = "postfix/mysql_mailbox_maps";
38 user = config.services.postfix.user;
39 group = config.services.postfix.group;
40 permissions = "0440";
41 text = ''
42 # We need to specify that option to trigger ssl connection
43 tls_ciphers = TLSv1.2
ab8f306d
IB
44 user = ${config.myEnv.mail.postfix.mysql.user}
45 password = ${config.myEnv.mail.postfix.mysql.password}
46 hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
47 dbname = ${config.myEnv.mail.postfix.mysql.database}
8415083e
IB
48 result_format = /%d/%u
49 query = SELECT DISTINCT '%s'
50 FROM mailboxes
51 WHERE active = 1
52 AND (
53 (domain = '%d' AND user = '%u' AND regex = 0)
54 OR (
55 regex = 1
56 AND '%d' REGEXP CONCAT('^',domain,'$')
57 AND '%u' REGEXP CONCAT('^',user,'$')
58 )
a929614f 59 )
8415083e 60 LIMIT 1
a929614f 61 '';
8415083e
IB
62 }
63 {
64 dest = "postfix/mysql_sender_login_maps";
65 user = config.services.postfix.user;
66 group = config.services.postfix.group;
67 permissions = "0440";
68 text = ''
69 # We need to specify that option to trigger ssl connection
70 tls_ciphers = TLSv1.2
ab8f306d
IB
71 user = ${config.myEnv.mail.postfix.mysql.user}
72 password = ${config.myEnv.mail.postfix.mysql.password}
73 hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
74 dbname = ${config.myEnv.mail.postfix.mysql.database}
8415083e
IB
75 query = SELECT DISTINCT destination
76 FROM forwardings_merge
77 WHERE
78 ((regex = 1 AND '%s' REGEXP CONCAT('^',source,'$') ) OR (regex = 0 AND source = '%s'))
79 AND active = 1
80 UNION SELECT '%s' AS destination
81 '';
82 }
87a8bffd
IB
83 {
84 dest = "postfix/mysql_sender_relays_maps";
85 user = config.services.postfix.user;
86 group = config.services.postfix.group;
87 permissions = "0440";
88 text = ''
89 # We need to specify that option to trigger ssl connection
90 tls_ciphers = TLSv1.2
91 user = ${config.myEnv.mail.postfix.mysql.user}
92 password = ${config.myEnv.mail.postfix.mysql.password}
93 hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
94 dbname = ${config.myEnv.mail.postfix.mysql.database}
95 # INSERT INTO sender_relays
96 # (`from`, owner, relay, login, password, regex, active)
97 # VALUES
98 # ( 'sender@otherhost.org'
99 # , 'me@mail.immae.eu'
100 # , '[otherhost.org]:587'
101 # , 'otherhostlogin'
102 # , AES_ENCRYPT('otherhostpassword', '${config.myEnv.mail.postfix.mysql.password_encrypt}')
103 # , '0'
104 # , '1');
105
106 query = SELECT DISTINCT `owner`
107 FROM sender_relays
108 WHERE
109 ((regex = 1 AND '%s' REGEXP CONCAT('^',`from`,'$') ) OR (regex = 0 AND `from` = '%s'))
110 AND active = 1
111 '';
112 }
113 {
114 dest = "postfix/mysql_sender_relays_hosts";
115 user = config.services.postfix.user;
116 group = config.services.postfix.group;
117 permissions = "0440";
118 text = ''
119 # We need to specify that option to trigger ssl connection
120 tls_ciphers = TLSv1.2
121 user = ${config.myEnv.mail.postfix.mysql.user}
122 password = ${config.myEnv.mail.postfix.mysql.password}
123 hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
124 dbname = ${config.myEnv.mail.postfix.mysql.database}
125
126 query = SELECT DISTINCT relay
127 FROM sender_relays
128 WHERE
129 ((regex = 1 AND '%s' REGEXP CONCAT('^',`from`,'$') ) OR (regex = 0 AND `from` = '%s'))
130 AND active = 1
131 '';
132 }
133 {
134 dest = "postfix/mysql_sender_relays_creds";
135 user = config.services.postfix.user;
136 group = config.services.postfix.group;
137 permissions = "0440";
138 text = ''
139 # We need to specify that option to trigger ssl connection
140 tls_ciphers = TLSv1.2
141 user = ${config.myEnv.mail.postfix.mysql.user}
142 password = ${config.myEnv.mail.postfix.mysql.password}
143 hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
144 dbname = ${config.myEnv.mail.postfix.mysql.database}
145
146 query = SELECT DISTINCT CONCAT(`login`, ':', AES_DECRYPT(`password`, '${config.myEnv.mail.postfix.mysql.password_encrypt}'))
147 FROM sender_relays
148 WHERE
149 ((regex = 1 AND '%s' REGEXP CONCAT('^',`from`,'$') ) OR (regex = 0 AND `from` = '%s'))
150 AND active = 1
151 '';
152 }
5b53d86f
IB
153 {
154 dest = "postfix/ldap_ejabberd_users_immae_fr";
155 user = config.services.postfix.user;
156 group = config.services.postfix.group;
157 permissions = "0440";
158 text = ''
159 server_host = ldaps://${config.myEnv.jabber.ldap.host}:636
160 search_base = ${config.myEnv.jabber.ldap.base}
161 query_filter = ${config.myEnv.jabber.postfix_user_filter}
162 domain = immae.fr
163 bind_dn = ${config.myEnv.jabber.ldap.dn}
164 bind_pw = ${config.myEnv.jabber.ldap.password}
165 result_attribute = immaeXmppUid
166 result_format = ejabberd@localhost
167 version = 3
168 '';
169 }
8415083e 170 ];
a929614f 171
8415083e 172 networking.firewall.allowedTCPPorts = [ 25 465 587 ];
a929614f 173
8415083e
IB
174 nixpkgs.overlays = [ (self: super: {
175 postfix = super.postfix.override { withMySQL = true; };
176 }) ];
177 users.users."${config.services.postfix.user}".extraGroups = [ "keys" ];
178 services.filesWatcher.postfix = {
179 restart = true;
180 paths = [
181 config.secrets.fullPaths."postfix/mysql_alias_maps"
182 config.secrets.fullPaths."postfix/mysql_mailbox_maps"
183 config.secrets.fullPaths."postfix/mysql_sender_login_maps"
5b53d86f 184 config.secrets.fullPaths."postfix/ldap_ejabberd_users_immae_fr"
8415083e
IB
185 ];
186 };
187 services.postfix = {
2a61e9da
IB
188 extraAliases = let
189 toScript = name: script: pkgs.writeScript name ''
190 #! ${pkgs.stdenv.shell}
191 mail=$(${pkgs.coreutils}/bin/cat -)
192 output=$(echo "$mail" | ${script} 2>&1)
193 ret=$?
194
195 if [ "$ret" != "0" ]; then
196 echo "$mail" \
197 | ${pkgs.procmail}/bin/formail -i "X-Return-Code: $ret" \
198 | /run/wrappers/bin/sendmail -i scripts_error+${name}@mail.immae.eu
199
200 messageId=$(echo "$mail" | ${pkgs.procmail}/bin/formail -x "Message-Id:")
201 repeat=$(echo "$mail" | ${pkgs.procmail}/bin/formail -X "From:" -X "Received:")
202
203 ${pkgs.coreutils}/bin/cat <<EOF | /run/wrappers/bin/sendmail -i scripts_error+${name}@mail.immae.eu
204 $repeat
205 To: scripts_error+${name}@mail.immae.eu
206 Subject: Log from script error
207 Content-Type: text/plain; charset="UTF-8"
208 Content-Transfer-Encoding: 8bit
209 References:$messageId
210 MIME-Version: 1.0
211 X-Return-Code: $ret
212
213 Error code: $ret
214 Output of message:
215 --------------
216 $output
217 --------------
218 EOF
219 fi
220 '';
221 scripts = lib.attrsets.mapAttrs (n: v:
222 toScript n (pkgs.callPackage (builtins.fetchGit { url = v.src.url; ref = "master"; rev = v.src.rev; }) { scriptEnv = v.env; })
71a2425e
IB
223 ) config.myEnv.mail.scripts // {
224 testmail = pkgs.writeScript "testmail" ''
225 #! ${pkgs.stdenv.shell}
226 ${pkgs.coreutils}/bin/touch \
227 "/var/lib/naemon/checks/email/$(${pkgs.procmail}/bin/formail -x To: | ${pkgs.coreutils}/bin/tr -d ' <>')"
228 '';
229 };
2a61e9da 230 in builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList (n: v: ''${n}: "|${v}"'') scripts);
8415083e
IB
231 mapFiles = let
232 recipient_maps = let
233 name = n: i: "relay_${n}_${toString i}";
234 pair = n: i: m: lib.attrsets.nameValuePair (name n i) (
235 if m.type == "hash"
236 then pkgs.writeText (name n i) m.content
04b2ab97 237 else null
8415083e
IB
238 );
239 pairs = n: v: lib.imap1 (i: m: pair n i m) v.recipient_maps;
240 in lib.attrsets.filterAttrs (k: v: v != null) (
241 lib.attrsets.listToAttrs (lib.flatten (
ab8f306d 242 lib.attrsets.mapAttrsToList pairs config.myEnv.mail.postfix.backup_domains
8415083e
IB
243 ))
244 );
245 relay_restrictions = lib.attrsets.filterAttrs (k: v: v != null) (
246 lib.attrsets.mapAttrs' (n: v:
247 lib.attrsets.nameValuePair "recipient_access_${n}" (
248 if lib.attrsets.hasAttr "relay_restrictions" v
249 then pkgs.writeText "recipient_access_${n}" v.relay_restrictions
250 else null
251 )
ab8f306d 252 ) config.myEnv.mail.postfix.backup_domains
8415083e 253 );
2a61e9da 254 virtual_map = {
71a2425e
IB
255 virtual = let
256 cfg = config.myEnv.monitoring.email_check.eldiron;
257 address = "${cfg.mail_address}@${cfg.mail_domain}";
258 in pkgs.writeText "postfix-virtual" (
2a61e9da 259 builtins.concatStringsSep "\n" (
71a2425e 260 ["${address} testmail@localhost"] ++
2a61e9da 261 lib.attrsets.mapAttrsToList (
5b53d86f 262 n: v: lib.optionalString v.external ''
2a61e9da
IB
263 script_${n}@mail.immae.eu ${n}@localhost, scripts@mail.immae.eu
264 ''
ab8f306d 265 ) config.myEnv.mail.scripts
2a61e9da
IB
266 )
267 );
268 };
deca5e9b
IB
269 sasl_access = {
270 host_sender_login = pkgs.writeText "host-sender-login"
271 (builtins.concatStringsSep "\n" (lib.flatten (lib.attrsets.mapAttrsToList
272 (n: v: (map (e: "${e} ${n}@immae.eu") v.emails)) config.myEnv.servers)));
273 host_dummy_mailboxes = pkgs.writeText "host-virtual-mailbox"
274 (builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList (n: v: "${n}@immae.eu dummy") nodes));
275 };
8415083e 276 in
deca5e9b 277 recipient_maps // relay_restrictions // virtual_map // sasl_access;
8415083e
IB
278 config = {
279 ### postfix module overrides
280 readme_directory = "${pkgs.postfix}/share/postfix/doc";
281 smtp_tls_CAfile = lib.mkForce "";
282 smtp_tls_cert_file = lib.mkForce "";
283 smtp_tls_key_file = lib.mkForce "";
a929614f 284
8415083e 285 message_size_limit = "1073741824"; # Don't put 0 here, it's not equivalent to "unlimited"
2a61e9da 286 mailbox_size_limit = "1073741825"; # Workaround, local delivered mails should all go through scripts
8415083e 287 alias_database = "\$alias_maps";
a929614f 288
8415083e 289 ### Virtual mailboxes config
5b53d86f 290 virtual_alias_maps = "hash:/etc/postfix/virtual mysql:${config.secrets.fullPaths."postfix/mysql_alias_maps"} ldap:${config.secrets.fullPaths."postfix/ldap_ejabberd_users_immae_fr"}";
ab8f306d 291 virtual_mailbox_domains = config.myEnv.mail.postfix.additional_mailbox_domains
8415083e
IB
292 ++ lib.remove "localhost.immae.eu" (lib.remove null (lib.flatten (map
293 (zone: map
294 (e: if e.receive
295 then "${e.domain}${lib.optionalString (e.domain != "") "."}${zone.name}"
296 else null
297 )
298 (zone.withEmail or [])
a929614f 299 )
ab8f306d 300 config.myEnv.dns.masterZones
8415083e 301 )));
deca5e9b 302 virtual_mailbox_maps = "hash:/etc/postfix/host_dummy_mailboxes mysql:${config.secrets.fullPaths."postfix/mysql_mailbox_maps"}";
8415083e
IB
303 dovecot_destination_recipient_limit = "1";
304 virtual_transport = "dovecot";
a929614f 305
8415083e 306 ### Relay domains
ab8f306d 307 relay_domains = lib.flatten (lib.attrsets.mapAttrsToList (n: v: v.domains or []) config.myEnv.mail.postfix.backup_domains);
8415083e
IB
308 relay_recipient_maps = lib.flatten (lib.attrsets.mapAttrsToList (n: v:
309 lib.imap1 (i: m: "${m.type}:/etc/postfix/relay_${n}_${toString i}") v.recipient_maps
ab8f306d 310 ) config.myEnv.mail.postfix.backup_domains);
8415083e 311 smtpd_relay_restrictions = [
8415083e
IB
312 "defer_unauth_destination"
313 ] ++ lib.flatten (lib.attrsets.mapAttrsToList (n: v:
314 if lib.attrsets.hasAttr "relay_restrictions" v
315 then [ "check_recipient_access hash:/etc/postfix/recipient_access_${n}" ]
316 else []
ab8f306d 317 ) config.myEnv.mail.postfix.backup_domains);
a929614f 318
8415083e
IB
319 ### Additional smtpd configuration
320 smtpd_tls_received_header = "yes";
321 smtpd_tls_loglevel = "1";
a929614f 322
8415083e
IB
323 ### Email sending configuration
324 smtp_tls_security_level = "may";
325 smtp_tls_loglevel = "1";
a929614f 326
8415083e 327 ### Force ip bind for smtp
619e4f46
IB
328 smtp_bind_address = config.hostEnv.ips.main.ip4;
329 smtp_bind_address6 = builtins.head config.hostEnv.ips.main.ip6;
a929614f 330
87a8bffd
IB
331 # Use some relays when authorized senders are not myself
332 smtp_sasl_mechanism_filter = "plain,login"; # GSSAPI Not correctly supported by postfix
333 smtp_sasl_auth_enable = "yes";
334 smtp_sasl_password_maps =
335 "mysql:${config.secrets.fullPaths."postfix/mysql_sender_relays_creds"}";
336 smtp_sasl_security_options = "noanonymous";
337 smtp_sender_dependent_authentication = "yes";
338 sender_dependent_relayhost_maps =
339 "mysql:${config.secrets.fullPaths."postfix/mysql_sender_relays_hosts"}";
a929614f 340
8415083e
IB
341 ### opendkim, opendmarc, openarc milters
342 non_smtpd_milters = [
343 "unix:${config.myServices.mail.milters.sockets.opendkim}"
8415083e
IB
344 ];
345 smtpd_milters = [
346 "unix:${config.myServices.mail.milters.sockets.opendkim}"
8415083e 347 "unix:${config.myServices.mail.milters.sockets.openarc}"
619e4f46 348 "unix:${config.myServices.mail.milters.sockets.opendmarc}"
a929614f
IB
349 ];
350 };
8415083e
IB
351 enable = true;
352 enableSmtp = true;
353 enableSubmission = true;
354 submissionOptions = {
87a8bffd
IB
355 # Don’t use "long form", only commas (cf
356 # http://www.postfix.org/master.5.html long form is not handled
357 # well by the submission function)
8415083e
IB
358 smtpd_tls_security_level = "encrypt";
359 smtpd_sasl_auth_enable = "yes";
360 smtpd_tls_auth_only = "yes";
361 smtpd_sasl_tls_security_options = "noanonymous";
362 smtpd_sasl_type = "dovecot";
363 smtpd_sasl_path = "private/auth";
364 smtpd_reject_unlisted_recipient = "no";
365 smtpd_client_restrictions = "permit_sasl_authenticated,reject";
619e4f46 366 smtpd_relay_restrictions = "permit_sasl_authenticated,reject";
8415083e
IB
367 # Refuse to send e-mails with a From that is not handled
368 smtpd_sender_restrictions =
369 "reject_sender_login_mismatch,reject_unlisted_sender,permit_sasl_authenticated,reject";
87a8bffd
IB
370 smtpd_sender_login_maps = builtins.concatStringsSep "," [
371 "hash:/etc/postfix/host_sender_login"
372 "mysql:${config.secrets.fullPaths."postfix/mysql_sender_relays_maps"}"
373 "mysql:${config.secrets.fullPaths."postfix/mysql_sender_login_maps"}"
374 ];
8415083e
IB
375 smtpd_recipient_restrictions = "permit_sasl_authenticated,reject";
376 milter_macro_daemon_name = "ORIGINATING";
377 smtpd_milters = "unix:${config.myServices.mail.milters.sockets.opendkim}";
378 };
379 # FIXME: Mail adressed to localhost.immae.eu will still have mx-1 as
380 # prioritized MX, which provokes "mail for localhost.immae.eu loops
381 # back to myself" errors. This transport entry forces to push
382 # e-mails to its right destination.
383 transport = ''
384 localhost.immae.eu smtp:[immae.eu]:25
385 '';
386 destination = ["localhost"];
387 # This needs to reverse DNS
619e4f46 388 hostname = config.hostEnv.fqdn;
8415083e
IB
389 setSendmail = true;
390 sslCert = "/var/lib/acme/mail/fullchain.pem";
391 sslKey = "/var/lib/acme/mail/key.pem";
392 recipientDelimiter = "+";
393 masterConfig = {
394 submissions = {
395 type = "inet";
396 private = false;
397 command = "smtpd";
398 args = ["-o" "smtpd_tls_wrappermode=yes" ] ++ (let
399 mkKeyVal = opt: val: [ "-o" (opt + "=" + val) ];
400 in lib.concatLists (lib.mapAttrsToList mkKeyVal config.services.postfix.submissionOptions)
401 );
402 };
403 dovecot = {
404 type = "unix";
405 privileged = true;
406 chroot = false;
407 command = "pipe";
408 args = let
409 # rspamd could be used as a milter, but then it cannot apply
410 # its checks "per user" (milter is not yet dispatched to
411 # users), so we wrap dovecot-lda inside rspamc per recipient
412 # here.
dc6d3af9
IB
413 rspamc_dovecot = pkgs.writeScriptBin "rspamc_dovecot" ''
414 #! ${pkgs.stdenv.shell}
415 sender="$1"
416 original_recipient="$2"
417 user="$3"
418
419 ${pkgs.coreutils}/bin/cat - | \
420 (${pkgs.rspamd}/bin/rspamc -h ${config.myServices.mail.rspamd.sockets.worker-controller} -c bayes -d "$user" --mime || true) | \
421 ${pkgs.dovecot}/libexec/dovecot/dovecot-lda -f "$sender" -a "$original_recipient" -d "$user"
422 '';
8415083e
IB
423 in [
424 "flags=DRhu" "user=vhost:vhost"
dc6d3af9 425 "argv=${rspamc_dovecot}/bin/rspamc_dovecot \${sender} \${original_recipient} \${user}@\${nexthop}"
8415083e
IB
426 ];
427 };
428 };
a929614f 429 };
981fa803 430 security.acme2.certs."mail" = {
8415083e
IB
431 postRun = ''
432 systemctl restart postfix.service
433 '';
434 extraDomains = {
435 "smtp.immae.eu" = null;
436 };
a929614f 437 };
71a2425e
IB
438 system.activationScripts.testmail = {
439 deps = [ "users" ];
440 text = let
441 allCfg = config.myEnv.monitoring.email_check;
442 cfg = allCfg.eldiron;
443 reverseTargets = builtins.attrNames (lib.attrsets.filterAttrs (k: v: builtins.elem "eldiron" v.targets) allCfg);
444 to_email = cfg': host':
445 let sep = if lib.strings.hasInfix "+" cfg'.mail_address then "_" else "+";
446 in "${cfg'.mail_address}${sep}${host'}@${cfg'.mail_domain}";
447 mails_to_receive = builtins.concatStringsSep " " (map (to_email cfg) reverseTargets);
448 in ''
449 install -m 0555 -o nobody -g nogroup -d /var/lib/naemon/checks/email
450 for f in ${mails_to_receive}; do
451 if [ ! -f /var/lib/naemon/checks/email/$f ]; then
452 install -m 0644 -o nobody -g nogroup /dev/null -T /var/lib/naemon/checks/email/$f
453 touch -m -d @0 /var/lib/naemon/checks/email/$f
454 fi
455 done
456 '';
457 };
a929614f
IB
458 };
459}