]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - modules/private/default.nix
Update Chloé’s website
[perso/Immae/Config/Nix.git] / modules / private / default.nix
CommitLineData
f8026b6e
IB
1let
2set = {
581c499c 3 # adatped from nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
6c97d2d7
IB
4 httpdInte = import ../websites/httpd-service-builder.nix { httpdName = "Inte"; withUsers = false; };
5 httpdProd = import ../websites/httpd-service-builder.nix { httpdName = "Prod"; withUsers = false; };
6 httpdTools = import ../websites/httpd-service-builder.nix { httpdName = "Tools"; withUsers = true; };
182ae57f
IB
7
8 databases = ./databases;
9 mariadb = ./databases/mariadb.nix;
10 openldap = ./databases/openldap;
11 postgresql = ./databases/postgresql.nix;
12 redis = ./databases/redis.nix;
ec9b6564 13 postgresqlReplication = ./databases/postgresql_replication.nix;
9f6a7862 14 mariadbReplication = ./databases/mariadb_replication.nix;
dded6699 15 redisReplication = ./databases/redis_replication.nix;
16b80abd 16 openldapReplication = ./databases/openldap_replication.nix;
ffb14c1c 17
f8026b6e 18 websites = ./websites;
d3452fc5
IB
19
20
21 # Personal websites
22 capitainesLandingPages = ./websites/capitaines/landing_pages.nix;
23
f8026b6e
IB
24 chloeInte = ./websites/chloe/integration.nix;
25 chloeProd = ./websites/chloe/production.nix;
d3452fc5 26
f8026b6e
IB
27 connexionswingInte = ./websites/connexionswing/integration.nix;
28 connexionswingProd = ./websites/connexionswing/production.nix;
d3452fc5
IB
29
30 deniseDenisejeromeProd = ./websites/denise/denisejerome.nix;
31 deniseEvariste = ./websites/denise/evariste.nix;
32
33 emiliaMoodle = ./websites/emilia/moodle.nix;
34
f8026b6e
IB
35 florianApp = ./websites/florian/app.nix;
36 florianInte = ./websites/florian/integration.nix;
37 florianProd = ./websites/florian/production.nix;
d3452fc5 38
f8026b6e
IB
39 immaeProd = ./websites/immae/production.nix;
40 immaeRelease = ./websites/immae/release.nix;
41 immaeTemp = ./websites/immae/temp.nix;
d3452fc5
IB
42
43 isabelleAtenInte = ./websites/isabelle/aten_integration.nix;
44 isabelleAtenProd = ./websites/isabelle/aten_production.nix;
45 isabelleIridologie = ./websites/isabelle/iridologie.nix;
46
47 jeromeNaturaloutil = ./websites/jerome/naturaloutil.nix;
48
f8026b6e 49 leilaProd = ./websites/leila/production.nix;
d3452fc5
IB
50
51 ludivineInte = ./websites/ludivine/integration.nix;
52 ludivineProd = ./websites/ludivine/production.nix;
53
f8026b6e 54 nassimeProd = ./websites/nassime/production.nix;
d3452fc5 55
8722d693
IB
56 nathanaelVillon = ./websites/nathanael/villon.nix;
57
9a414bd6 58 papaMaisonBbc = ./websites/papa/maison_bbc.nix;
f8026b6e 59 papaSurveillance = ./websites/papa/surveillance.nix;
d3452fc5 60
f8026b6e
IB
61 piedsjalouxInte = ./websites/piedsjaloux/integration.nix;
62 piedsjalouxProd = ./websites/piedsjaloux/production.nix;
d3452fc5
IB
63
64 richieProd = ./websites/richie/production.nix;
65
8a05c7fb 66 sydenPeertube = ./websites/syden/peertube.nix;
f8026b6e 67
d3452fc5
IB
68 teliotortayProd = ./websites/telio_tortay/production.nix;
69
70 # Tools
4288c2f2
IB
71 cloudTool = ./websites/tools/cloud;
72 davTool = ./websites/tools/dav;
ea9c6fe8 73 vpnTool = ./websites/tools/vpn;
4288c2f2
IB
74 dbTool = ./websites/tools/db;
75 diasporaTool = ./websites/tools/diaspora;
76 etherTool = ./websites/tools/ether;
77 gitTool = ./websites/tools/git;
3f453c7d 78 imTool = ./websites/tools/im;
4288c2f2
IB
79 mastodonTool = ./websites/tools/mastodon;
80 mgoblinTool = ./websites/tools/mgoblin;
81 peertubeTool = ./websites/tools/peertube;
82 toolsTool = ./websites/tools/tools;
afcc5de0 83 mailTool = ./websites/tools/mail;
4288c2f2 84
de6002a1
IB
85 # Games
86 codenamesGame = ./websites/tools/games/codenames;
87
a929614f 88 mail = ./mail;
a929614f 89
8d213e2b
IB
90 buildbot = ./buildbot;
91 certificates = ./certificates.nix;
92 gitolite = ./gitolite;
ffb14c1c 93 irc = ./irc.nix;
8d213e2b
IB
94 pub = ./pub;
95 tasks = ./tasks;
96 dns = ./dns.nix;
97 ftp = ./ftp.nix;
8d213e2b 98 mpd = ./mpd.nix;
3f453c7d 99 ejabberd = ./ejabberd;
8d213e2b 100 ssh = ./ssh;
3bc32d9e 101 monitoring = ./monitoring;
6e9f30f4 102 status = ./monitoring/status.nix;
ea9c6fe8 103 vpn = ./vpn;
8d213e2b 104
ab8f306d 105 environment = ./environment.nix;
8d213e2b 106 system = ./system.nix;
7f286353 107 loginctl-linger = ./loginctl-linger.nix;
f8026b6e
IB
108};
109in
110builtins.listToAttrs (map (attr: { name = "priv${attr}"; value = set.${attr}; }) (builtins.attrNames set))