]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - flakes/mypackages/pkgs/webapps/phpldapadmin/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / pkgs / webapps / phpldapadmin / default.nix
CommitLineData
693f27df 1{ config ? "/etc/phpldapadmin/config.php", fetchurl, fetchFromGitHub, stdenv, optipng }:
f5efae0f 2stdenv.mkDerivation rec {
693f27df 3 version = "1.2.5";
f5efae0f 4 name = "phpldapadmin-${version}";
693f27df
IB
5 src = fetchFromGitHub {
6 owner = "leenooks";
7 repo = "phpLDAPadmin";
8 rev = "8f4ced96f9c63a09510a5bccb2189a8b92fb29ba";
9 sha256 = "1x6xc3xbvw3aj46i5ds06a8h6mfljxdv3argxrzz02l541ra6ni7";
f5efae0f
IB
10 };
11 patches = [
693f27df
IB
12 #./ldap-php5_5.patch
13 #./ldap-disable-mcrypt.patch
14 #./ldap-php7_2.patch
f5efae0f
IB
15 ./ldap-sort-in-templates.patch
16 ./ldap-align-button.patch
693f27df 17 ./ldap-fix-password.patch
f5efae0f
IB
18 ];
19 buildInputs = [ optipng ];
20 buildPhase = ''
21 find -name '*.png' -exec optipng -quiet -force -fix {} \;
22 '';
23 installPhase = ''
24 cp -a . $out
25 ln -sf ${config} $out/config/config.php
26 '';
27}