]> git.immae.eu Git - perso/Immae/Config/Nix.git/blame - default.nix
Improve iota cli app build
[perso/Immae/Config/Nix.git] / default.nix
CommitLineData
676e68e3 1with import <nixpkgs> { overlays = builtins.attrValues (import ./overlays); };
676e68e3
IB
2 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
3 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
4 {
5 boinctui = callPackage ./pkgs/boinctui {};
dff8b593 6 cnagios = callPackage ./pkgs/cnagios {};
676e68e3 7 duply = callPackage ./pkgs/duply {};
dff8b593 8 flrn = callPackage ./pkgs/flrn { slang = callPackage ./pkgs/slang_1 {}; };
676e68e3
IB
9 genius = callPackage ./pkgs/genius {};
10 mtop = callPackage ./pkgs/mtop {};
11 muttprint = callPackage ./pkgs/muttprint {};
dff8b593
IB
12 mutt-ics = callPackage ./pkgs/mutt-ics {};
13 nagios-cli = callPackage ./pkgs/nagios-cli {};
14 #nagnu = callPackage ./pkgs/nagnu {};
676e68e3
IB
15 note = callPackage ./pkgs/note {};
16 notmuch-python2 = callPackage ./pkgs/notmuch/notmuch-python { pythonPackages = python2Packages; };
17 notmuch-python3 = callPackage ./pkgs/notmuch/notmuch-python { pythonPackages = python3Packages; };
18 notmuch-vim = callPackage ./pkgs/notmuch/notmuch-vim {};
dff8b593
IB
19 pg_activity = callPackage ./pkgs/pg_activity {};
20 pgloader = callPackage ./pkgs/pgloader {};
21 telegram-cli = callPackage ./pkgs/telegram-cli {};
22 telegram-history-dump = callPackage ./pkgs/telegram-history-dump {};
23 telegramircd = callPackage ./pkgs/telegramircd { telethon = callPackage ./pkgs/telethon_sync {}; };
676e68e3
IB
24 terminal-velocity = callPackage ./pkgs/terminal-velocity {};
25 tiv = callPackage ./pkgs/tiv {};
26 unicode = callPackage ./pkgs/unicode {};
27
dff8b593
IB
28 cardano = callPackage ./pkgs/crypto/cardano {};
29 iota-cli-app = callPackage ./pkgs/crypto/iota-cli-app {};
676e68e3
IB
30 sia = callPackage ./pkgs/crypto/sia {};
31 } // { # overlays
32 inherit weboob;
33 inherit taskwarrior;
34 inherit slrn;
35 inherit sc-im;
36 inherit lesspipe;
37 inherit neomutt;
38 inherit weechat;
39 inherit goaccess;
40 inherit profanity;
41 inherit nixops;
42 inherit dwm;
43 inherit vit;
44 inherit pass;
45 inherit elinks;
46 inherit pelican;
47 inherit ldapvi;
48 inherit (mylibs.yarn2nixPackage) yarn2nix;
49 } // {
ac6bfec2 50 inherit nix-prefetch-scripts;
9f7e0ed0 51 inherit nix-generate-from-cpan;
b7cb5556 52 inherit timewarrior;
6b53d116 53 inherit pal;
6b53d116
IB
54 inherit pdftk;
55 inherit googler;
56 inherit jrnl;
f8dbac30 57 inherit apg pwgen;
6b53d116
IB
58 inherit newsboat;
59 inherit vcsh;
60 inherit xmr-stak;
61 inherit urlwatch;
3936ddc5 62 inherit ranger;
b7cb5556 63 inherit irssi;
9106eaf4
IB
64 inherit abook khard khal;
65 inherit graphicsmagick;
66 inherit youtube-dl;
e229e6f2 67 inherit ncmpc ncmpcpp;
892cb808
IB
68 inherit cadaver;
69 inherit mairix notmuch;
70 inherit ctags;
71 inherit s3cmd;
72 inherit solc; # solidity
73 inherit rtorrent;
74 inherit strace;
75 inherit vdirsyncer;
76 inherit w3m lynx links;
77 inherit gitRepo;
78 inherit valgrind;
dab1955f
IB
79 inherit iotop iperf;
80 inherit keybase;
81 inherit bogofilter;
a98e2320 82 inherit mtr;
0a03d9d7 83 inherit urlview;
42f4b42d 84 inherit rr;
ea9d3f4b 85 inherit nix-zsh-completions;
4795e024 86 inherit browsh;
5cae8acf 87 inherit monero;
55fd3780
IB
88 inherit nextcloud-client;
89 inherit feh imagemagick;
f8dbac30 90 inherit lftp;
7590e6bd 91 stgit = gitAndTools.stgit;
a7f7fdae 92 inherit bundix;
bb3210df 93 bower2nix = nodePackages.bower2nix;
b236d74d 94 inherit firefox;
39256be8
IB
95 inherit jq;
96 inherit lzo unzip bzip2 p7zip xz;
97 # unrar is unfree
98 inherit tig;
39256be8
IB
99 inherit emacs26-nox;
100 inherit highlight sourceHighlight;
101 pygmentize = python3Packages.pygments;
93fea40a
IB
102 inherit iftop htop;
103 inherit fetchmail;
104 inherit bc;
105 inherit cpulimit;
45cbd03c 106 inherit dmenu st;
80a3e055
IB
107 inherit poppler_utils;
108 inherit tmux;
109 inherit netcat-gnu;
1f8d6a9a 110 inherit ledger;
994f70bd 111 inherit ffmpeg libxslt;
fcf18de4 112 }