]> git.immae.eu Git - perso/Immae/Config/AUR.git/blobdiff - dash-static/PKGBUILD
Add 'dash-static/' from commit 'af87ed0a69deebf7b400d8f8d88ce2342913b7fa'
[perso/Immae/Config/AUR.git] / dash-static / PKGBUILD
diff --git a/dash-static/PKGBUILD b/dash-static/PKGBUILD
new file mode 100644 (file)
index 0000000..9a9e1e7
--- /dev/null
@@ -0,0 +1,25 @@
+# Maintainer : Immae <ismael.bouya@normalesup.org>
+
+pkgname=dash-static
+pkgver=0.5.10.2
+pkgrel=1
+pkgdesc="POSIX compliant shell that aims to be as small as possible. Statically compiled"
+arch=('x86_64')
+url="http://gondor.apana.org.au/~herbert/dash/"
+license=('BSD')
+source=("http://gondor.apana.org.au/~herbert/dash/files/dash-${pkgver}.tar.gz")
+sha512sums=('0ae29be77794df0ba254967649b9728611a75fbb3acd32ab6634d76399d1ce97c7d12d31da465482a7e4f3207093415c496c39525cace9b78ab3cb9444dd7640')
+
+
+build () {
+  cd "dash-$pkgver"
+  export CC="gcc -static"
+  export CFLAGS="-Os -static"
+  ./configure --with-libedit
+  make
+}
+
+package() {
+  cd "dash-$pkgver"
+  install -Dm755 src/dash $pkgdir/usr/bin/dash-static
+}