]> git.immae.eu Git - perso/Immae/Config/AUR.git/blame - dwm-git/PKGBUILD
Initial upload: openarc-git v1.0.0.Beta1.r0.g355ee2a-1
[perso/Immae/Config/AUR.git] / dwm-git / PKGBUILD
CommitLineData
ccddfb5d 1pkgname=dwm-git-custom
15615832 2_pkgname=dwm
c5ce61ac 3pkgver=6.2_029b988
5b832282 4pkgrel=1
15615832
BB
5pkgdesc="A dynamic window manager for X"
6url="http://dwm.suckless.org"
7arch=('i686' 'x86_64')
8license=('MIT')
9options=(zipman)
142e2a99 10depends=('libx11' 'libxinerama' 'libxft')
15615832
BB
11makedepends=('git')
12install=dwm.install
13provides=('dwm')
14conflicts=('dwm')
15epoch=1
b8795ba1
BB
16source=(dwm.desktop
17 "$_pkgname::git+http://git.suckless.org/dwm")
18md5sums=('939f403a71b6e85261d09fc3412269ee'
19 'SKIP')
15615832 20
4aef1176
BB
21pkgver(){
22 cd $_pkgname
c5ce61ac 23 echo $(git describe --tags |sed 's/-/./g')_$(md5sum $SRCDEST/config.h | cut -c1-7)
4aef1176
BB
24}
25
15615832 26prepare() {
4aef1176 27 cd $_pkgname
ccddfb5d
IB
28 if [[ -f "$SRCDEST/config.h" ]]; then
29 cp -f "$SRCDEST/config.h" config.h
15615832
BB
30 fi
31}
32
33build() {
34 cd $_pkgname
35 make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
36}
37
38package() {
4aef1176
BB
39 cd $_pkgname
40 make PREFIX=/usr DESTDIR="$pkgdir" install
41 install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
42 install -m644 -D README "$pkgdir/usr/share/doc/$pkgname/README"
43 install -m644 -D ../dwm.desktop "$pkgdir/usr/share/xsessions/dwm.desktop"
15615832
BB
44}
45
46# vim:set ts=2 sw=2 et: