]> git.immae.eu Git - perso/Immae/Config/AUR.git/blame - dash-static/PKGBUILD
Split 'editline/' into commit 'b9aebd1750d435e8588fd602d746ac2374aba471'
[perso/Immae/Config/AUR.git] / dash-static / PKGBUILD
CommitLineData
af87ed0a
IB
1# Maintainer : Immae <ismael.bouya@normalesup.org>
2
3pkgname=dash-static
4pkgver=0.5.10.2
5pkgrel=1
6pkgdesc="POSIX compliant shell that aims to be as small as possible. Statically compiled"
7arch=('x86_64')
8url="http://gondor.apana.org.au/~herbert/dash/"
9license=('BSD')
10source=("http://gondor.apana.org.au/~herbert/dash/files/dash-${pkgver}.tar.gz")
11sha512sums=('0ae29be77794df0ba254967649b9728611a75fbb3acd32ab6634d76399d1ce97c7d12d31da465482a7e4f3207093415c496c39525cace9b78ab3cb9444dd7640')
12
13
14build () {
15 cd "dash-$pkgver"
16 export CC="gcc -static"
17 export CFLAGS="-Os -static"
18 ./configure --with-libedit
19 make
20}
21
22package() {
23 cd "dash-$pkgver"
24 install -Dm755 src/dash $pkgdir/usr/bin/dash-static
25}