]> git.immae.eu Git - perso/Denise/aventuriers.git/blob - shell.nix
Add shell.nix
[perso/Denise/aventuriers.git] / shell.nix
1 let nixpkgs = import (builtins.fetchTarball {
2 name = "nixos-unstable";
3 url = "https://github.com/NixOS/nixpkgs/archive/8e2b14aceb1d40c7e8b84c03a7c78955359872bb.tar.gz";
4 sha256 = "0zzjpd9smr7rxzrdf6raw9kbj42fbvafxb5bz36lcxgv290pgsm8";
5 }) { overlays = []; config = {}; };
6 in
7 { pkgs ? nixpkgs }:
8 let
9 copy = pkgs.writeScriptBin "copy" ''
10 #!${pkgs.stdenv.shell}
11
12 cp "$@"
13 '';
14 in
15 pkgs.mkShell {
16 buildInputs = [
17 pkgs.gnumake pkgs.calibre copy pkgs.inkscape_0
18 (pkgs.texlive.combine {
19 inherit (pkgs.texlive) scheme-small preprint fourier
20 collection-plaingeneric datetime fmtcount;
21 })
22 ];
23 }
24