]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/packages/nextcloud.nix
Bubble up the imports to the main file
[perso/Immae/Config/Nix.git] / virtual / packages / nextcloud.nix
index ff4b923d9d11ce132a8dc81430add787c2b90b57..d332a1047e9e85c3481386e270fe28445c0c1bb0 100644 (file)
@@ -1,11 +1,10 @@
-with import ../../libs.nix;
-with nixpkgs_unstable;
+{ stdenv, fetchurl, checkEnv, writeText, lib }:
 let
   nextcloud = let
     # FIXME: initial sync
     # FIXME: backup
     buildApp = { appName, version, url, sha256, installPhase ? "mkdir -p $out && cp -R . $out/" }:
-      pkgs.stdenv.mkDerivation rec {
+      stdenv.mkDerivation rec {
         name = "nextcloud-app-${appName}-${version}";
         inherit version;
         phases = "unpackPhase installPhase";
@@ -106,7 +105,7 @@ let
       assert checkEnv "NIXOPS_NEXTCLOUD_INSTANCE_ID";
       assert checkEnv "NIXOPS_NEXTCLOUD_SECRET";
       assert checkEnv "NIXOPS_NEXTCLOUD_REDIS_DB_INDEX";
-      pkgs.writeText "config.php" ''
+      writeText "config.php" ''
       <?php
       $CONFIG = array (
         'instanceid' => '${builtins.getEnv "NIXOPS_NEXTCLOUD_INSTANCE_ID"}',
@@ -183,16 +182,16 @@ let
         rm -r $out/config
         ln -sf ${config} $out/config
         ${builtins.concatStringsSep "\n" (
-          pkgs.lib.attrsets.mapAttrsToList (name: value: "ln -sf ${value} $out/apps/${name}") apps
+          lib.attrsets.mapAttrsToList (name: value: "ln -sf ${value} $out/apps/${name}") apps
         )}
       '';
 
       meta = {
         description = "Sharing solution for files, calendars, contacts and more";
         homepage = https://nextcloud.com;
-        maintainers = with stdenv.lib.maintainers; [ schneefux bachp globin fpletz ];
-        license = stdenv.lib.licenses.agpl3Plus;
-        platforms = with stdenv.lib.platforms; unix;
+        maintainers = with lib.maintainers; [ schneefux bachp globin fpletz ];
+        license = lib.licenses.agpl3Plus;
+        platforms = with lib.platforms; unix;
       };
     };
     activationScript = {
@@ -229,7 +228,7 @@ let
     phpFpm = rec {
       basedir = builtins.concatStringsSep ":" (
         [ webRoot varDir config ]
-        ++ pkgs.lib.attrsets.mapAttrsToList (name: value: value) apps);
+        ++ lib.attrsets.mapAttrsToList (name: value: value) apps);
       socket = "/var/run/phpfpm/nextcloud.sock";
       pool = ''
         listen = ${socket}