]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/packages/mantisbt.nix
Bubble up the imports to the main file
[perso/Immae/Config/Nix.git] / virtual / packages / mantisbt.nix
index f136ea53bbd5f11af168b8577b9b48a7371e749b..82fc8ad15e8f424f957046311a9ceae17b69b7a8 100644 (file)
@@ -1,5 +1,4 @@
-with import ../../libs.nix;
-with nixpkgs_unstable;
+{ lib, checkEnv, writeText, stdenv, fetchurl, fetchedGithub }:
 let
   # FIXME: check that source-integration and slack still work
   mantisbt = let
@@ -23,7 +22,7 @@ let
       assert checkEnv "NIXOPS_MANTISBT_DB_PASSWORD";
       assert checkEnv "NIXOPS_MANTISBT_MASTER_SALT";
       assert checkEnv "NIXOPS_MANTISBT_LDAP_PASSWORD";
-      pkgs.writeText "config_inc.php" ''
+      writeText "config_inc.php" ''
       <?php
       $g_hostname              = 'db-1.immae.eu';
       $g_db_username           = 'mantisbt';
@@ -102,7 +101,7 @@ let
     phpFpm = rec {
       basedir = builtins.concatStringsSep ":" (
         [ webRoot config ]
-        ++ pkgs.lib.attrsets.mapAttrsToList (name: value: value) plugins);
+        ++ lib.attrsets.mapAttrsToList (name: value: value) plugins);
       socket = "/var/run/phpfpm/mantisbt.sock";
       pool = ''
         listen = ${socket}