]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/packages/adminer.nix
Bubble up the imports to the main file
[perso/Immae/Config/Nix.git] / virtual / packages / adminer.nix
index 35fa791932fa128d597989a4e8d78ee3c406463d..034f0d47124d0aa5d6574ab79090714b1ad931d3 100644 (file)
@@ -1,11 +1,10 @@
-with import ../../libs.nix;
-with nixpkgs_unstable;
+{ stdenv, fetchurl, nginx }:
 let
   adminer = rec {
-    webRoot = pkgs.stdenv.mkDerivation rec {
+    webRoot = stdenv.mkDerivation rec {
       version = "4.7.0";
       name = "adminer-${version}";
-      src = pkgs.fetchurl {
+      src = fetchurl {
         url = "https://www.adminer.org/static/download/${version}/${name}.php";
         sha256 = "1qq2g7rbfh2vrqfm3g0bz0qs057b049n0mhabnsbd1sgnpvnc5z7";
       };
@@ -48,7 +47,7 @@ let
       alias = webRoot;
       index = "index.php";
       extraConfig = ''
-        include ${pkgs.nginx}/conf/fastcgi.conf;
+        include ${nginx}/conf/fastcgi.conf;
         fastcgi_split_path_info ^(.+?\.php)(/.*)$;
         fastcgi_param HTTP_PROXY "";
         fastcgi_param SCRIPT_FILENAME ${webRoot}/index.php;