]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/tools/tools/ympd.nix
Rename virtual folder to nixops
[perso/Immae/Config/Nix.git] / virtual / modules / websites / tools / tools / ympd.nix
diff --git a/virtual/modules/websites/tools/tools/ympd.nix b/virtual/modules/websites/tools/tools/ympd.nix
deleted file mode 100644 (file)
index 5744360..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-{ env }:
-let
-  ympd = rec {
-    config = {
-      webPort = "localhost:${env.listenPort}";
-      mpd = env.mpd;
-    };
-    apache = {
-      modules = [
-        "proxy_wstunnel"
-        ];
-      vhostConf = ''
-        <LocationMatch "^/mpd">
-          Use LDAPConnect
-          Require ldap-group   cn=users,cn=mpd,ou=services,dc=immae,dc=eu
-          Require local
-        </LocationMatch>
-
-        RedirectMatch permanent "^/mpd$" "/mpd/"
-        <Location "/mpd/">
-          ProxyPass http://${config.webPort}/
-          ProxyPassReverse http://${config.webPort}/
-          ProxyPreserveHost on
-        </Location>
-        <Location "/mpd/ws">
-          ProxyPass ws://${config.webPort}/ws
-        </Location>
-      '';
-    };
-  };
-in
-  ympd