]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/tools/tools/default.nix
Add wallabag
[perso/Immae/Config/Nix.git] / virtual / modules / websites / tools / tools / default.nix
index f29ac11097ca158c5b29e6768724420413d12bd0..d69ccc9c6497142a9a44ffa507a694af664a8d3d 100644 (file)
@@ -4,6 +4,7 @@ let
     ympd = pkgs.callPackage ./ympd.nix {};
     ttrss = pkgs.callPackage ./ttrss.nix { inherit (mylibs) checkEnv fetchedGithub fetchedGit; };
     roundcubemail = pkgs.callPackage ./roundcubemail.nix { inherit (mylibs) checkEnv; };
+    wallabag = pkgs.callPackage ./wallabag.nix { inherit (mylibs) checkEnv; };
 
     cfg = config.services.myWebsites.tools.tools;
 in {
@@ -18,7 +19,8 @@ in {
       adminer.apache.modules
       ++ ympd.apache.modules
       ++ ttrss.apache.modules
-      ++ roundcubemail.apache.modules;
+      ++ roundcubemail.apache.modules
+      ++ wallabag.apache.modules;
 
     services.ympd = ympd.config // { enable = false; };
 
@@ -31,6 +33,7 @@ in {
         ympd.apache.vhostConf
         ttrss.apache.vhostConf
         roundcubemail.apache.vhostConf
+        wallabag.apache.vhostConf
       ];
     };
 
@@ -38,11 +41,13 @@ in {
       adminer = adminer.phpFpm.pool;
       ttrss = ttrss.phpFpm.pool;
       roundcubemail = roundcubemail.phpFpm.pool;
+      wallabag = wallabag.phpFpm.pool;
     };
 
     system.activationScripts = {
       ttrss = ttrss.activationScript;
       roundcubemail = roundcubemail.activationScript;
+      wallabag = wallabag.activationScript;
     };
 
     systemd.services.tt-rss = {