]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/tools/tools/default.nix
Add yourls
[perso/Immae/Config/Nix.git] / virtual / modules / websites / tools / tools / default.nix
index f29ac11097ca158c5b29e6768724420413d12bd0..7fb4974bd7687a006ca5fe85876e1c4dc07c3575 100644 (file)
@@ -1,9 +1,17 @@
-{ lib, pkgs, config, mylibs, ... }:
+{ lib, pkgs, config, myconfig, mylibs, ... }:
 let
     adminer = pkgs.callPackage ../../commons/adminer.nix {};
     ympd = pkgs.callPackage ./ympd.nix {};
-    ttrss = pkgs.callPackage ./ttrss.nix { inherit (mylibs) checkEnv fetchedGithub fetchedGit; };
-    roundcubemail = pkgs.callPackage ./roundcubemail.nix { inherit (mylibs) checkEnv; };
+    ttrss = pkgs.callPackage ./ttrss.nix {
+      inherit (mylibs) fetchedGithub fetchedGit;
+      env = myconfig.env.tools.ttrss;
+    };
+    roundcubemail = pkgs.callPackage ./roundcubemail.nix { env = myconfig.env.tools.roundcubemail; };
+    wallabag = pkgs.callPackage ./wallabag.nix { env = myconfig.env.tools.wallabag; };
+    yourls = pkgs.callPackage ./yourls.nix {
+      inherit (mylibs) fetchedGithub;
+      env = myconfig.env.tools.yourls;
+    };
 
     cfg = config.services.myWebsites.tools.tools;
 in {
@@ -18,7 +26,9 @@ in {
       adminer.apache.modules
       ++ ympd.apache.modules
       ++ ttrss.apache.modules
-      ++ roundcubemail.apache.modules;
+      ++ roundcubemail.apache.modules
+      ++ wallabag.apache.modules
+      ++ yourls.apache.modules;
 
     services.ympd = ympd.config // { enable = false; };
 
@@ -31,6 +41,8 @@ in {
         ympd.apache.vhostConf
         ttrss.apache.vhostConf
         roundcubemail.apache.vhostConf
+        wallabag.apache.vhostConf
+        yourls.apache.vhostConf
       ];
     };
 
@@ -38,11 +50,15 @@ in {
       adminer = adminer.phpFpm.pool;
       ttrss = ttrss.phpFpm.pool;
       roundcubemail = roundcubemail.phpFpm.pool;
+      wallabag = wallabag.phpFpm.pool;
+      yourls = yourls.phpFpm.pool;
     };
 
     system.activationScripts = {
       ttrss = ttrss.activationScript;
       roundcubemail = roundcubemail.activationScript;
+      wallabag = wallabag.activationScript;
+      yourls = yourls.activationScript;
     };
 
     systemd.services.tt-rss = {