]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/tools/mastodon/default.nix
Fix some errors (service timouts and mastodon missing paths) after first reboot
[perso/Immae/Config/Nix.git] / virtual / modules / websites / tools / mastodon / default.nix
index b2170b50a4856ff4f6ca1c52fe755c73e2d36e09..d25a072967cd4eb2efddffde0d360fc7c45472b0 100644 (file)
@@ -88,7 +88,7 @@ in {
         EnvironmentFile = mastodon.config;
         PrivateTmp = true;
         Restart = "always";
-        TimeoutSec = 15;
+        TimeoutSec = 60;
         Type = "simple";
         WorkingDirectory = mastodon.railsRoot;
       };
@@ -96,6 +96,7 @@ in {
       unitConfig.RequiresMountsFor = mastodon.varDir;
     };
 
+    # FIXME: monitor jobs
     systemd.services.mastodon-sidekiq = {
       description = "Mastodon Sidekiq";
       wantedBy = [ "multi-user.target" ];
@@ -104,7 +105,7 @@ in {
       environment.RAILS_ENV="production";
       environment.DB_POOL="5";
 
-      path = [ pkgs.bundler pkgs.file ];
+      path = [ pkgs.imagemagick pkgs.ffmpeg pkgs.bundler pkgs.file ];
 
       script = ''
         exec bundle exec sidekiq -c 5 -q default -q mailers -q pull -q push