]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/tools/mastodon/default.nix
Move all fixmes to mantisbt issue tracking
[perso/Immae/Config/Nix.git] / virtual / modules / websites / tools / mastodon / default.nix
index b2170b50a4856ff4f6ca1c52fe755c73e2d36e09..25a389bc1684805ef1474ba30fa001200ada9fc5 100644 (file)
@@ -11,8 +11,6 @@ in {
   };
 
   config = lib.mkIf cfg.enable {
-    # FIXME: Can we use dynamic users from systemd?
-    # nixos/modules/misc/ids.nix
     ids.uids.mastodon = 399;
     ids.gids.mastodon = 399;
 
@@ -88,7 +86,7 @@ in {
         EnvironmentFile = mastodon.config;
         PrivateTmp = true;
         Restart = "always";
-        TimeoutSec = 15;
+        TimeoutSec = 60;
         Type = "simple";
         WorkingDirectory = mastodon.railsRoot;
       };
@@ -104,7 +102,7 @@ in {
       environment.RAILS_ENV="production";
       environment.DB_POOL="5";
 
-      path = [ pkgs.bundler pkgs.file ];
+      path = [ pkgs.imagemagick pkgs.ffmpeg pkgs.bundler pkgs.file ];
 
       script = ''
         exec bundle exec sidekiq -c 5 -q default -q mailers -q pull -q push
@@ -123,7 +121,6 @@ in {
       unitConfig.RequiresMountsFor = mastodon.varDir;
     };
 
-    # FIXME: initial sync
     system.activationScripts.mastodon = {
       deps = [ "users" ];
       text = ''
@@ -134,7 +131,6 @@ in {
 
     services.myWebsites.tools.modules = [
       "headers" "proxy" "proxy_wstunnel" "proxy_http" "proxy_balancer"
-      # FIXME: probably only one balancer method is needed:
       "lbmethod_byrequests" "lbmethod_bytraffic" "lbmethod_bybusyness" "lbmethod_heartbeat"
     ];
     security.acme.certs."eldiron".extraDomains."mastodon.immae.eu" = null;