]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/tellesflorian/default.nix
Rename virtual folder to nixops
[perso/Immae/Config/Nix.git] / virtual / modules / websites / tellesflorian / default.nix
diff --git a/virtual/modules/websites/tellesflorian/default.nix b/virtual/modules/websites/tellesflorian/default.nix
deleted file mode 100644 (file)
index f347169..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-{ lib, pkgs, config, myconfig, mylibs, ... }:
-let
-    adminer = pkgs.callPackage ../commons/adminer.nix {};
-
-    tellesflorian = pkgs.callPackage ./tellesflorian.nix { inherit (mylibs) fetchedGitPrivate; };
-    tellesflorian_dev  = tellesflorian {
-      config = myconfig.env.websites.tellesflorian.integration;
-    };
-
-    cfg = config.services.myWebsites.TellesFlorian;
-in {
-  options.services.myWebsites.TellesFlorian = {
-    integration = {
-      enable = lib.mkEnableOption "enable Florian Telles's website in integration";
-    };
-  };
-
-  config = lib.mkIf cfg.integration.enable {
-    security.acme.certs."eldiron".extraDomains."app.tellesflorian.com" = null;
-    services.myPhpfpm.poolConfigs.tellesflorian_dev = tellesflorian_dev.phpFpm.pool;
-    system.activationScripts.tellesflorian_dev = tellesflorian_dev.activationScript;
-    services.myWebsites.integration.modules = adminer.apache.modules ++ tellesflorian_dev.apache.modules;
-    services.myWebsites.integration.vhostConfs.tellesflorian = {
-      certName    = "eldiron";
-      hosts       = ["app.tellesflorian.com" ];
-      root        = tellesflorian_dev.webRoot;
-      extraConfig = [
-        tellesflorian_dev.apache.vhostConf
-        adminer.apache.vhostConf
-      ];
-    };
-  };
-}