]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/default.nix
Fix deprecation for networking addresses in hetzner
[perso/Immae/Config/Nix.git] / virtual / modules / websites / default.nix
index 55ded8ac8e65c0208047980f6281b312a74b1691..f2f0be11c30e6791ef9cacf8578f76c0936f3c7d 100644 (file)
@@ -83,6 +83,8 @@ let
       });
     };
   };
+  makeModules = cfg: pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
+  makeExtraConfig = cfg: (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
 in
 {
   imports = [
@@ -98,6 +100,8 @@ in
     ./tools/cloud
     ./tools/git
     ./tools/mastodon
+    ./tools/mediagoblin
+    ./tools/diaspora
     # built using:
     # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
     # Removed allGranted
@@ -173,6 +177,8 @@ in
     services.myWebsites.tools.cloud.enable = true;
     services.myWebsites.tools.git.enable = true;
     services.myWebsites.tools.mastodon.enable = true;
+    services.myWebsites.tools.mediagoblin.enable = true;
+    services.myWebsites.tools.diaspora.enable = true;
 
     services.myWebsites.Chloe.production.enable = cfg.production.enable;
     services.myWebsites.Ludivine.production.enable = cfg.production.enable;
@@ -199,7 +205,6 @@ in
       };
       ldap = {
         modules = [ "ldap" "authnz_ldap" ];
-        # FIXME: starttls
         extraConfig = assert mylibs.checkEnv "NIXOPS_HTTP_LDAP_PASSWORD"; ''
           <IfModule ldap_module>
             LDAPSharedCacheSize 500000
@@ -232,6 +237,16 @@ in
               Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
             </Location>
           </Macro>
+
+          ErrorDocument 500 /maintenance_immae.html
+          ErrorDocument 501 /maintenance_immae.html
+          ErrorDocument 502 /maintenance_immae.html
+          ErrorDocument 503 /maintenance_immae.html
+          ErrorDocument 504 /maintenance_immae.html
+          Alias /maintenance_immae.html ${../../www}/maintenance_immae.html
+          ProxyPass /maintenance_immae.html !
+
+          AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${../../www}/googleb6d69446ff4ca3e5.html
         '';
       };
       http2 = {
@@ -269,18 +284,26 @@ in
         '';
     };
 
-    # FIXME: logrotate
-    # FIXME: ipv6
     services.httpdProd = makeService "production" config.services.myWebsites.production;
-    services.myWebsites.production.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
-    services.myWebsites.production.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
+    services.myWebsites.production.modules = makeModules cfg;
+    services.myWebsites.production.extraConfig = makeExtraConfig cfg;
 
     services.httpdInte = makeService "integration" config.services.myWebsites.integration;
-    services.myWebsites.integration.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
-    services.myWebsites.integration.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
+    services.myWebsites.integration.modules = makeModules cfg;
+    services.myWebsites.integration.extraConfig = makeExtraConfig cfg;
 
     services.httpdTools = makeService "tools" config.services.myWebsites.tools;
-    services.myWebsites.tools.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
-    services.myWebsites.tools.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
+    services.myWebsites.tools.modules = makeModules cfg;
+    services.myWebsites.tools.extraConfig = makeExtraConfig cfg ++
+    [ ''
+        RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
+        RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
+        RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
+        RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
+        RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
+        RedirectMatch ^/CGU$ https://www.immae.eu/CGU
+      ''
+      ]
+    ;
   };
 }