]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/default.nix
Add httpdTools service
[perso/Immae/Config/Nix.git] / virtual / modules / websites / default.nix
index 6b313811edc46f88004e645ee0fd0bac25f2b7f9..55ded8ac8e65c0208047980f6281b312a74b1691 100644 (file)
@@ -91,16 +91,21 @@ in
     ./aten
     ./piedsjaloux
     ./connexionswing
+    ./tellesflorian
     ./tools/db
     ./tools/tools
     ./tools/dav
     ./tools/cloud
     ./tools/git
+    ./tools/mastodon
     # built using:
     # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
+    # Removed allGranted
     # And removed users / groups
     ./apache/httpd_prod.nix
     ./apache/httpd_inte.nix
+    # except for this one for users/groups
+    ./apache/httpd_tools.nix
     # Adapted from base phpfpm
     ./phpfpm
   ];
@@ -167,6 +172,7 @@ in
     services.myWebsites.tools.dav.enable = true;
     services.myWebsites.tools.cloud.enable = true;
     services.myWebsites.tools.git.enable = true;
+    services.myWebsites.tools.mastodon.enable = true;
 
     services.myWebsites.Chloe.production.enable = cfg.production.enable;
     services.myWebsites.Ludivine.production.enable = cfg.production.enable;
@@ -179,6 +185,7 @@ in
     services.myWebsites.Aten.integration.enable = cfg.integration.enable;
     services.myWebsites.PiedsJaloux.integration.enable = cfg.integration.enable;
     services.myWebsites.Connexionswing.integration.enable = cfg.integration.enable;
+    services.myWebsites.TellesFlorian.integration.enable = true;
 
     services.myWebsites.apacheConfig = {
       gzip = {
@@ -272,7 +279,7 @@ in
     services.myWebsites.integration.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
     services.myWebsites.integration.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
 
-    services.httpd = makeService "tools" config.services.myWebsites.tools;
+    services.httpdTools = makeService "tools" config.services.myWebsites.tools;
     services.myWebsites.tools.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
     services.myWebsites.tools.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
   };