]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/eldiron.nix
Move some more configuration for websites
[perso/Immae/Config/Nix.git] / virtual / eldiron.nix
index e1edc01e271b1594d7befb4d28607e42129c8476..fa5cb5123c95b9b5609fddb3ffc03e77993c3562 100644 (file)
@@ -8,7 +8,7 @@
     with mylibs;
     let
         mypkgs = pkgs.callPackage ./packages.nix {
-          inherit checkEnv fetchedGit fetchedGitPrivate fetchedGithub;
+          inherit checkEnv fetchedGit fetchedGithub;
         };
     in
   {
@@ -28,7 +28,7 @@
       ./modules/gitolite.nix
       ./modules/gitweb.nix
       ./modules/databases.nix
-      ./modules/websites.nix
+      ./modules/websites
     ];
     services.myGitolite.enable = true;
     services.myGitweb.enable = true;
     networking = {
       firewall = {
         enable = true;
-        allowedTCPPorts = [ 22 80 443 9418 ];
+        allowedTCPPorts = [ 22 9418 ];
       };
-      interfaces."eth0".ipv4.addresses = [
-        # 176.9.151.89 declared in nixops -> infra / tools
-        { address = myconfig.ips.production; prefixLength = 32; }
-        { address = myconfig.ips.integration; prefixLength = 32; }
-      ];
     };
 
     deployment = {
             mypkgs.davical.apache.vhostConf
           ];
         })
-        (withConf "connexionswing" // {
-          hostName = "connexionswing.com";
-          serverAliases = [ "sandetludo.com" "www.connexionswing.com" "www.sandetludo.com" ];
-          documentRoot = mypkgs.connexionswing_prod.webRoot;
-          extraConfig = builtins.concatStringsSep "\n" [
-            mypkgs.connexionswing_prod.apache.vhostConf
-          ];
-        })
-        (withConf "ludivinecassal" // {
-          hostName = "ludivinecassal.com";
-          serverAliases = [ "www.ludivinecassal.com" ];
-          documentRoot = mypkgs.ludivinecassal_prod.webRoot;
-          extraConfig = builtins.concatStringsSep "\n" [
-            mypkgs.ludivinecassal_prod.apache.vhostConf
-          ];
-        })
-        (withConf "piedsjaloux" // {
-          hostName = "piedsjaloux.fr";
-          serverAliases = [ "www.piedsjaloux.fr" ];
-          documentRoot = mypkgs.piedsjaloux_prod.webRoot;
-          extraConfig = builtins.concatStringsSep "\n" [
-            mypkgs.piedsjaloux_prod.apache.vhostConf
-          ];
-        })
-        (withConf "chloe" // {
-          hostName = "osteopathe-cc.fr";
-          serverAliases = [ "www.osteopathe-cc.fr" ];
-          documentRoot = mypkgs.chloe_prod.webRoot;
-          extraConfig = builtins.concatStringsSep "\n" [
-            mypkgs.chloe_prod.apache.vhostConf
-          ];
-        })
-        (withConf "aten" // {
-          hostName = "aten.pro";
-          serverAliases = [ "www.aten.pro" ];
-          documentRoot = mypkgs.aten_prod.webRoot;
-          extraConfig = builtins.concatStringsSep "\n" [
-            mypkgs.aten_prod.apache.vhostConf
-          ];
-        })
         (withConf "eldiron" // {
           hostName = "cloud.immae.eu";
           documentRoot = mypkgs.nextcloud.webRoot;