]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/eldiron.nix
Replace unstable with stable in environment
[perso/Immae/Config/Nix.git] / virtual / eldiron.nix
index 63106d603da53da37694a1fa8d4c1f659b80fcf7..71ff57d78fceca7a06efb7b36fac362186bdf3c8 100644 (file)
@@ -7,19 +7,27 @@
   eldiron = { config, pkgs, ... }:
     with import ../libs.nix;
     let
-        mypkgs = nixpkgs_unstable.callPackage ./packages.nix {
+        mypkgs = pkgs.callPackage ./packages.nix {
           inherit checkEnv fetchedGitPrivate fetchedGithub;
-          gitwebOverride = nixpkgs_unstable.gitweb.overrideAttrs(old: {
-            installPhase = old.installPhase + ''
-              cp -r ${./packages/gitweb} $out/gitweb-theme;
-              '';
-          });
         };
     in
   {
-    # FIXME: they are not overriden in packages.nix
-    # (see nix-store -q --tree /nix/var/nix/profiles/system)
     nixpkgs.config.packageOverrides = oldpkgs: rec {
+      gitolite = oldpkgs.gitolite.overrideAttrs(old: rec {
+        name = "gitolite-${version}";
+        version = "3.6.10";
+        src = pkgs.fetchFromGitHub {
+          owner = "sitaramc";
+          repo = "gitolite";
+          rev = "v${version}";
+          sha256 = "0p2697mn6rwm03ndlv7q137zczai82n41aplq1g006ii7f12xy8h";
+        };
+      });
+      gitweb = oldpkgs.gitweb.overrideAttrs(old: {
+        installPhase = old.installPhase + ''
+          cp -r ${./packages/gitweb} $out/gitweb-theme;
+          '';
+      });
       postgresql = postgresql111;
       postgresql111 = oldpkgs.postgresql100.overrideAttrs(old: rec {
         passthru = old.passthru // { psqlSchema = "11.0"; };
         extension=${pkgs.phpPackages.redis}/lib/php/extensions/redis.so
         ; For nextcloud
         extension=${pkgs.phpPackages.apcu}/lib/php/extensions/apcu.so
+        ; For nextcloud
+        zend_extension=${pkgs.php}/lib/php/extensions/opcache.so
         '';
       extraConfig = ''
         log_level = notice
     };
 
     services.httpd = let
-      withSSL = domain: {
+      withConf = domain: {
         enableSSL = true;
         sslServerCert = "/var/lib/acme/${domain}/cert.pem";
         sslServerKey = "/var/lib/acme/${domain}/key.pem";
         sslServerChain = "/var/lib/acme/${domain}/fullchain.pem";
+        logFormat = "combinedVhost";
+        listen = [ { ip = "*"; port = 443; } ];
       };
       apacheConfig = {
         gzip = {
             </Macro>
           '';
         };
+        http2 = {
+          modules = [ "http2" ];
+          extraConfig = ''
+            Protocols h2 http/1.1
+          '';
+        };
+        customLog = {
+          modules = [];
+          extraConfig = ''
+            LogFormat "%v %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %p" combinedVhost
+          '';
+        };
       };
     in rec {
       enable = true;
       logPerVirtualHost = true;
       multiProcessingModule = "worker";
       adminAddr = "httpd@immae.eu";
-      # FIXME: http2
-      # FIXME: voir les autres modules:
-      #    authz_core_module
-      #    reqtimeout_module
-      #    http2_module
-      #    version_module
-      #    proxy_connect_module
-      #    proxy_ftp_module
-      #    proxy_scgi_module
-      #    proxy_ajp_module
-      #    proxy_balancer_module
-      #    proxy_express_module
-      #    lbmethod_byrequests_module
-      #    lbmethod_bytraffic_module
-      #    lbmethod_bybusyness_module
-      #    lbmethod_heartbeat_module
-
+      logFormat = "combinedVhost";
       extraModules = pkgs.lib.lists.unique (
         mypkgs.adminer.apache.modules ++
         mypkgs.nextcloud.apache.modules ++
       extraConfig = builtins.concatStringsSep "\n"
         (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig) apacheConfig);
       virtualHosts = [
-        (withSSL "eldiron" // {
-          listen = [ { ip = "*"; port = 443; } ];
+        (withConf "eldiron" // {
           hostName = "eldiron.immae.eu";
           documentRoot = ./www;
           extraConfig = ''
             DirectoryIndex index.htm
             '';
         })
-        (withSSL "eldiron" // {
-          listen = [ { ip = "*"; port = 443; } ];
+        (withConf "eldiron" // {
           hostName = "db-1.immae.eu";
           documentRoot = null;
           extraConfig = builtins.concatStringsSep "\n" [
             mypkgs.adminer.apache.vhostConf
           ];
         })
-        (withSSL "eldiron" // {
-          listen = [ { ip = "*"; port = 443; } ];
+        (withConf "eldiron" // {
           hostName = "tools.immae.eu";
           documentRoot = null;
           extraConfig = builtins.concatStringsSep "\n" [
             mypkgs.ympd.apache.vhostConf
           ];
         })
-        (withSSL "eldiron" // {
-          listen = [ { ip = "*"; port = 443; } ];
+        (withConf "eldiron" // {
           hostName = "connexionswing.immae.eu";
           serverAliases = [ "sandetludo.immae.eu" ];
           documentRoot = mypkgs.connexionswing_dev.webRoot;
             mypkgs.connexionswing_dev.apache.vhostConf
           ];
         })
-        (withSSL "eldiron" // {
-          listen = [ { ip = "*"; port = 443; } ];
+        (withConf "eldiron" // {
           hostName = "cloud.immae.eu";
           documentRoot = mypkgs.nextcloud.webRoot;
           extraConfig = builtins.concatStringsSep "\n" [
             mypkgs.nextcloud.apache.vhostConf
           ];
         })
-        (withSSL "eldiron" // {
-          listen = [ { ip = "*"; port = 443; } ];
+        (withConf "eldiron" // {
           hostName = "git.immae.eu";
           documentRoot = mypkgs.git.web.webRoot;
           extraConfig = builtins.concatStringsSep "\n" [
           hostName = "redirectSSL";
           serverAliases = [ "*" ];
           enableSSL = false;
+          logFormat = "combinedVhost";
           documentRoot = "/var/lib/acme/acme-challenge";
           extraConfig = ''
             RewriteEngine on