]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/eldiron.nix
Add Connexionswing
[perso/Immae/Config/Nix.git] / virtual / eldiron.nix
index fb366b7dffe0ed3826a8e72a2ce3b983d1961fd5..56c6afd318141de368caf4e371675ae067bb6a7e 100644 (file)
@@ -49,6 +49,8 @@
         extraDomains = {
           "db-1.immae.eu" = null;
           "tools.immae.eu" = null;
+          "connexionswing.immae.eu" = null;
+          "sandetludo.immae.eu" = null;
         };
       };
     };
@@ -62,6 +64,7 @@
         '';
       poolConfigs = {
         adminer = mypkgs.adminer.phpFpm.pool;
+        connexionswing_dev = mypkgs.connexionswing_dev.phpFpm.pool;
         www = ''
           listen = /var/run/phpfpm/www.sock
           user = wwwrun
       };
     };
 
+    system.activationScripts = {
+      connexionswing_dev  = mypkgs.connexionswing_dev.activationScript;
+    };
+
     services.httpd = let
       withSSL = domain: {
         enableSSL = true;
@@ -92,6 +99,7 @@
       # FIXME: http2
       extraModules = pkgs.lib.lists.unique (
         mypkgs.adminer.apache.modules ++
+        mypkgs.connexionswing_dev.apache.modules ++
         [
           "macro"
           "ldap"
             mypkgs.ympd.apache.vhostConf
           ];
         })
+        (withSSL "eldiron" // {
+          listen = [ { ip = "*"; port = 443; } ];
+          hostName = "connexionswing.immae.eu";
+          serverAliases = [ "sandetludo.immae.eu" ];
+          documentRoot = mypkgs.connexionswing_dev.webRoot;
+          extraConfig = builtins.concatStringsSep "\n" [
+            mypkgs.connexionswing_dev.apache.vhostConf
+          ];
+        })
         { # Should go last, default fallback
           listen = [ { ip = "*"; port = 80; } ];
           hostName = "redirectSSL";