]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/eldiron.nix
Improve postgresql: allow replication from backup-1, change root to
[perso/Immae/Config/Nix.git] / virtual / eldiron.nix
index ad94fb2799b74bf21d122b3741ec57bdb5ab2919..2e4ae1272cfb46265b5b09d7d1ff1635e9f4cee5 100644 (file)
@@ -4,6 +4,9 @@
     enableRollback = true;
   };
 
+  # Full backup:
+  # The star after /var/lib/* avoids deleting all folders in case of problem
+  # rsync -e "ssh -i /root/.ssh/id_charon_vpn" -aAXvz --delete --numeric-ids --super --rsync-path="sudo rsync" /var/lib/* immae@immae.eu:
   eldiron = { config, pkgs, mylibs, myconfig, ... }:
     with mylibs;
     let
@@ -28,7 +31,7 @@
       ./modules/gitolite.nix
       ./modules/gitweb.nix
       ./modules/databases.nix
-      ./modules/websites.nix
+      ./modules/websites
     ];
     services.myGitolite.enable = true;
     services.myGitweb.enable = true;
     networking = {
       firewall = {
         enable = true;
-        allowedTCPPorts = [ 22 80 443 9418 ];
+        allowedTCPPorts = [ 22 9418 ];
       };
-      interfaces."eth0".ipv4.addresses = [
-        # 176.9.151.89 declared in nixops -> infra / tools
-        { address = myconfig.ips.production; prefixLength = 32; }
-        { address = myconfig.ips.integration; prefixLength = 32; }
-      ];
     };
 
     deployment = {