]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - systems/monitoring-1/base.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / systems / monitoring-1 / base.nix
diff --git a/systems/monitoring-1/base.nix b/systems/monitoring-1/base.nix
new file mode 100644 (file)
index 0000000..8bfacc1
--- /dev/null
@@ -0,0 +1,75 @@
+{ config, pkgs, lib, nixpkgs, php, secrets, ... }:
+{
+  # ssh-keyscan monitoring-1 | nix-shell -p ssh-to-age --run ssh-to-age
+  secrets.ageKeys = [ "age1dn4lzhgxusqrpjjnzm7w8ml39ptf326htuzmpqdqs2gg3wq7cqzqxuvx8k" ];
+  boot.kernelPackages = pkgs.linuxPackages_latest;
+
+  imports = [
+    secrets.nixosModules.users-config-monitoring-1
+    (nixpkgs + "/nixos/modules/profiles/qemu-guest.nix")
+    ./monitoring-master.nix
+    ./monitoring.nix
+    ./status.nix
+    ./status_engine.nix
+  ];
+
+  nixpkgs.overlays = builtins.attrValues php.overlays;
+  nixpkgs.config.permittedInsecurePackages = [
+    "python-2.7.18.6" # for nagios-cli
+  ];
+
+  myServices.monitoring.enable = true;
+  myServices.monitoring.master = true;
+  myServices.status.enable = true;
+  networking = {
+    firewall.enable = true;
+    interfaces."ens3".ipv4.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
+      (n: ips: map (ip: { address = ip; prefixLength = 32; }) (ips.ip4 or []))
+      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.hostEnv.ips));
+    interfaces."ens3".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
+      (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
+      config.hostEnv.ips);
+    defaultGateway6 = { address = "fe80::1"; interface = "ens3"; };
+  };
+  boot.loader.grub.device = "nodev";
+  fileSystems."/" = { device = "/dev/sda1"; fsType = "ext4"; };
+  myServices.mailRelay.enable = true;
+
+  security.pki.certificateFiles = [
+    (pkgs.fetchurl {
+      url = "http://downloads.e.eriomem.net/eriomemca.pem";
+      sha256 = "1ixx4c6j3m26j8dp9a3dkvxc80v1nr5aqgmawwgs06bskasqkvvh";
+    })
+  ];
+
+  services.netdata.enable = true;
+  services.netdata.configDir."stream.conf" = config.secrets.fullPaths."netdata-stream.conf";
+  services.netdata.config.web."allow dashboard from" = "localhost";
+  services.netdata.config.web."allow badges from" = "*";
+  services.netdata.config.web."allow streaming from" = "*";
+  services.netdata.config.web."allow netdata.conf from" = "fd*";
+  services.netdata.config.web."allow management from" = "fd*";
+  networking.firewall.allowedTCPPorts = [ 19999 ];
+
+  secrets.keys = {
+    "netdata-stream.conf" = {
+      user = config.services.netdata.user;
+      group = config.services.netdata.group;
+      permissions = "0400";
+      text = builtins.concatStringsSep "\n" (pkgs.lib.mapAttrsToList (_: key: ''
+        [${key}]
+            enabled = yes
+            default history = 3600
+            default memory = ram
+            health enabled by default = auto
+      '') config.myEnv.monitoring.netdata_keys);
+    };
+  };
+  users.users."${config.services.netdata.user}".extraGroups = [ "keys" ];
+  # This value determines the NixOS release with which your system is
+  # to be compatible, in order to avoid breaking some software such as
+  # database servers. You should change this only after NixOS release
+  # notes say you should.
+  # https://nixos.org/nixos/manual/release-notes.html
+  system.stateVersion = "23.05"; # Did you read the comment?
+}