]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - systems/eldiron/websites/git/mantisbt.nix
Mantisbt bump
[perso/Immae/Config/Nix.git] / systems / eldiron / websites / git / mantisbt.nix
index 3bd78e13980f31212655c5ca1e9953bca82025c2..b0ee5535087c9f826d6162b34c969cc9c341ab3c 100644 (file)
@@ -6,6 +6,10 @@ rec {
     permissions = "0400";
     text = ''
       <?php
+      $g_admin_checks          = OFF;
+      $g_reauthentication      = OFF;
+      $g_reauthentication_expiry = 604800;
+      $g_path                  = 'https://git.immae.eu/mantisbt/';
       $g_hostname              = '${env.postgresql.socket}';
       $g_db_username           = '${env.postgresql.user}';
       $g_db_password           = '${env.postgresql.password}';
@@ -29,6 +33,7 @@ rec {
       $g_login_method = LDAP;
       $g_ldap_protocol_version = 3;
       $g_ldap_server = 'ldaps://${env.ldap.host}:636';
+      $g_ldap_use_starttls = OFF;
       $g_ldap_root_dn = 'ou=users,${env.ldap.base}';
       $g_ldap_bind_dn = '${env.ldap.dn}';
       $g_ldap_bind_passwd = '${env.ldap.password}';
@@ -39,7 +44,8 @@ rec {
       $g_ldap_organization = '${env.ldap.filter}';
     '';
   };
-  webRoot = (mantisbt_2.override { mantis_config = config.secrets.fullPaths."webapps/tools-mantisbt"; }).withPlugins (p: [p.slack p.source-integration]);
+  webRoot = (mantisbt_2.override { mantis_config =
+    config.secrets.fullPaths."webapps/tools-mantisbt"; }).withPlugins (p: [p.slack p.source-integration ]);
   apache = rec {
     user = "wwwrun";
     group = "wwwrun";