]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - systems/eldiron/dns.nix
Add mail autoconfiguration
[perso/Immae/Config/Nix.git] / systems / eldiron / dns.nix
index 857b233cefd6d868db4cfee287a658974229dea9..3d5aafa4401707fcff2b93ac5cf81fbf1e5df8a2 100644 (file)
@@ -50,7 +50,11 @@ in
           };
         };
         mailSend = {
-          # DKIM
+          # DKIM 2048b
+          subdomains._domainkey.subdomains.eldiron2.TXT = [
+            (toKV config.myEnv.mail.dkim.eldiron2.public)
+          ];
+          # DKIM 1024b
           subdomains._domainkey.subdomains.eldiron.TXT = [
             (toKV config.myEnv.mail.dkim.eldiron.public)
           ];
@@ -89,6 +93,11 @@ in
             # DMARC
             # p needs to be the first tag
             _dmarc.TXT = [ (toKV { _00__v = "DMARC1"; _01__p = if quarantine then "quarantine" else "none"; adkim = "s"; aspf = "s"; fo = "1"; rua = "mailto:postmaster+rua@immae.eu"; ruf = "mailto:postmaster+ruf@immae.eu"; }) ];
+
+            # Autoconfiguration for Outlook
+            autodiscover = ips servers.eldiron.ips.main;
+            # Autoconfiguration for Mozilla
+            autoconfig = ips servers.eldiron.ips.main;
           };
 
           # SPF