]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/webapps/nextcloud/apps/gpxpod.nix
Add flake skeletons
[perso/Immae/Config/Nix.git] / pkgs / webapps / nextcloud / apps / gpxpod.nix
diff --git a/pkgs/webapps/nextcloud/apps/gpxpod.nix b/pkgs/webapps/nextcloud/apps/gpxpod.nix
deleted file mode 100644 (file)
index f0b9881..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-{ buildApp, nextcloudVersion }:
-let
-  gpxpod_4_2_8 = buildApp rec {
-    appName = "gpxpod";
-    version = "4.2.8";
-    url = "https://gitlab.com/eneiluj/gpxpod-oc/wikis/uploads/630aee117900664644669890e6693383/${appName}-${version}.tar.gz";
-    sha256 = "1v47153zwxgfcw0ls4qppi1asa4kbgzbysqvfhs6lhv1pfpml5l4";
-    otherConfig = {
-      mimetypealiases = {
-        "application/gpx+xml" = "gpx";
-      };
-      mimetypemapping = {
-        "gpx" = ["application/gpx+xml"];
-      };
-    };
-  };
-  gpxpod_4_3_0 = buildApp rec {
-    appName = "gpxpod";
-    version = "4.3.0";
-    url = "https://gitlab.com/eneiluj/gpxpod-oc/wikis/uploads/89555a30934ebbe34c3a515aabd1781a/${appName}-${version}.tar.gz";
-    sha256 = "02l1iq5d7bzl2y3igfgs0v6hbvn6b8rxxq7lcvsax0ksmry4d314";
-    otherConfig = {
-      mimetypealiases = {
-        "application/gpx+xml" = "gpx";
-      };
-      mimetypemapping = {
-        "gpx" = ["application/gpx+xml"];
-      };
-    };
-  };
-  versions = {
-    "19" = gpxpod_4_2_8;
-    "20" = gpxpod_4_2_8;
-    "21" = gpxpod_4_2_8;
-    "22" = gpxpod_4_3_0;
-    "23" = gpxpod_4_3_0;
-  };
-in
-  versions."${builtins.toString nextcloudVersion}" or (throw "Unsupported version for nextcloud app gpxpod")