]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/webapps/default.nix
Rename davical config field to avoid clash
[perso/Immae/Config/Nix.git] / pkgs / webapps / default.nix
index 50c3543b84443a17662bbadfdded6d4b0d223c77..109eb6db237b0f232c9f89cd29e3b677755a7869 100644 (file)
@@ -10,6 +10,7 @@ rec {
   infcloud = callPackage ./infcloud {};
 
   nextcloud = callPackage ./nextcloud {};
+  nextcloud-with-apps = nextcloud.withPlugins (builtins.attrValues nextcloud-apps);
   nextcloud-apps = let
       names = [
         "audioplayer" "bookmarks" "calendar" "contacts" "deck"
@@ -25,4 +26,12 @@ rec {
   phpldapadmin = callPackage ./phpldapadmin {};
 
   rompr = callPackage ./rompr { inherit mylibs; };
+
+  mantisbt_2 = callPackage ./mantisbt_2 {};
+  mantisbt_2-with-plugins = mantisbt_2.withPlugins (builtins.attrValues mantisbt_2-plugins);
+  mantisbt_2-plugins = let
+    names = [ "slack" "source-integration" ];
+  in
+    lib.attrsets.genAttrs names
+      (name: callPackage (./mantisbt_2/plugins + "/${name}") {});
 }