]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/terminal-velocity/default.nix
Start splitting nix environment to smaller files
[perso/Immae/Config/Nix.git] / pkgs / terminal-velocity / default.nix
diff --git a/pkgs/terminal-velocity/default.nix b/pkgs/terminal-velocity/default.nix
new file mode 100644 (file)
index 0000000..9e79dee
--- /dev/null
@@ -0,0 +1,33 @@
+{ python36Packages }:
+with python36Packages;
+buildPythonApplication rec {
+  pname = "terminal-velocity-git";
+  version = "0.2.0";
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "13yrkcmvh5h5fwnai61sbmqkrjyisz08n62pq0ada2lyyqf7g6b9";
+  };
+
+  patches = [
+    ./sort_found_notes.patch
+    ./python3_support.patch
+    # FIXME: update this patch when version changes
+    ./fix_build.patch
+  ];
+
+  propagatedBuildInputs = [
+    chardet
+    urwid
+    (sh.overridePythonAttrs { doCheck = false; })
+    pyyaml
+  ];
+  buildInputs = [
+    m2r
+    (restructuredtext_lint.overridePythonAttrs { doCheck = false; })
+    pygments
+  ];
+
+  postInstall = ''
+    rm $out/bin/terminal_velocity
+    '';
+}