]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/openarc/default.nix
Add opendmarc openarc and opendkim configuration and packages
[perso/Immae/Config/Nix.git] / pkgs / openarc / default.nix
diff --git a/pkgs/openarc/default.nix b/pkgs/openarc/default.nix
new file mode 100644 (file)
index 0000000..e5c9a81
--- /dev/null
@@ -0,0 +1,18 @@
+{ stdenv, autoconf, automake, file, libtool, libbsd, mylibs, openssl, pkg-config, libmilter }:
+
+stdenv.mkDerivation (mylibs.fetchedGithub ./openarc.json // rec {
+  buildInputs = [ automake autoconf libbsd libtool openssl pkg-config libmilter ];
+
+  configureFlags = [
+    "--with-milter=${libmilter}"
+  ];
+  preConfigure = ''
+    autoreconf --force --install
+    sed -i -e "s@/usr/bin/file@${file}/bin/file@" ./configure
+    '';
+  meta = with stdenv.lib; {
+    description = "Open source ARC implementation";
+    homepage = https://github.com/trusteddomainproject/OpenARC;
+    platforms = platforms.unix;
+  };
+})