]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/default.nix
Add ntfy notification pusher
[perso/Immae/Config/Nix.git] / pkgs / default.nix
index 204f751a4384657ba33fe8b56058020491cf066f..6f817d9078727acc2357798f8be8837ccba5ac8b 100644 (file)
@@ -6,12 +6,13 @@ in
 rec {
   sources = import ../nix/sources.nix;
   myEnvironments = callPackage ../environments {};
+  bash-libs = callPackage ./bash-libs {};
   boinctui = callPackage ./boinctui {};
   cnagios = callPackage ./cnagios { inherit mylibs; };
   commento = callPackage ./commento {};
-  cryptpad = callPackage ./cryptpad {};
-  duply = callPackage ./duply {};
   flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
+  fluentd = callPackage ./fluentd {};
+  fluent-bit = callPackage ./fluent-bit {};
   genius = callPackage ./genius {};
   mtop = callPackage ./mtop {};
   muttprint = callPackage ./muttprint {};
@@ -21,16 +22,12 @@ rec {
   nb = callPackage ./nb {};
   note = callPackage ./note {};
   notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
-  notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
+  notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python38Packages; };
   notmuch-vim = callPackage ./notmuch/notmuch-vim {};
-  pg_activity = callPackage ./pg_activity { inherit mylibs; };
-  pgloader = callPackage ./pgloader {};
+  pgpid = callPackage ./pgpid {};
   predixy = callPackage ./predixy { inherit mylibs; };
   rrsync_sudo = callPackage ./rrsync_sudo {};
-  signald = callPackage ./signald {};
   signaldctl = callPackage ./signaldctl {};
-  stgit = callPackage ./stgit {};
-  telegram-cli = callPackage ./telegram-cli { inherit mylibs; };
   telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
   telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
   terminal-velocity = callPackage ./terminal-velocity {};
@@ -44,11 +41,8 @@ rec {
   iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
   sia = callPackage ./crypto/sia {};
 
+  proftpd = callPackage ./proftpd {};
   pure-ftpd = callPackage ./pure-ftpd {};
-  mpd = (callPackage ./mpd_0_21 {}).mpd;
-  mpd-small = (callPackage ./mpd_0_21 {}).mpd-small;
-
-  bitlbee-mastodon = callPackage ./bitlbee-mastodon {};
 
   composerEnv = callPackage ./composer-env {};
   webapps = callPackage ./webapps { inherit mylibs composerEnv; };
@@ -64,17 +58,10 @@ rec {
   };
 
   python3PackagesPlus = callPackage ./python-packages {
-    python = python3;
+    python = python38;
     inherit mylibs;
   };
   dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
     inherit mylibs;
   };
-  dovecot_fts-xapian = callPackage ./dovecot/plugins/fts_xapian {
-    inherit mylibs;
-  };
-
-  fiche = callPackage ./fiche { inherit mylibs; };
-  woob = python3Packages.callPackage ./woob {};
-  zrepl = callPackage ./zrepl {};
 }