]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/tools/ttrss.nix
Cleanup e-mails from immae.eu domains
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / ttrss.nix
index 95cca9d68f819eb20860874e0f102304abf2081d..ca049e69b2a77f87a2ff6d98d143a193f17f48cd 100644 (file)
@@ -94,16 +94,11 @@ let
         define('SPHINX_INDEX', 'ttrss, delta');
 
         define('ENABLE_REGISTRATION', false);
-        define('REG_NOTIFY_ADDRESS', 'outils@immae.eu');
+        define('REG_NOTIFY_ADDRESS', 'ttrss@tools.immae.eu');
         define('REG_MAX_USERS', 10);
 
-        define('SMTP_SERVER', 'mail.immae.eu:25');
-        define('SMTP_LOGIN', ''');
-        define('SMTP_PASSWORD', ''');
-        define('SMTP_SECURE', 'tls');
-
         define('SMTP_FROM_NAME', 'Tiny Tiny RSS');
-        define('SMTP_FROM_ADDRESS', 'outils@immae.eu');
+        define('SMTP_FROM_ADDRESS', 'ttrss@tools.immae.eu');
         define('DIGEST_SUBJECT', '[tt-rss] New headlines for last 24 hours');
 
         define('LDAP_AUTH_SERVER_URI', 'ldap://ldap.immae.eu:389/');
@@ -123,7 +118,7 @@ let
     webRoot = stdenv.mkDerivation (fetchedGit ./tt-rss.json // rec {
       buildPhase = ''
         rm -rf lock feed-icons cache
-        ln -sf ../../../../../${varDir}/{lock,feed-icons,cache} .
+        ln -sf ${varDir}/{lock,feed-icons,cache} .
       '';
       installPhase = ''
         cp -a . $out
@@ -133,13 +128,15 @@ let
         )}
       '';
     });
-    apache = {
+    apache = rec {
       user = "wwwrun";
       group = "wwwrun";
       modules = [ "proxy_fcgi" ];
+      webappName = "tools_ttrss";
+      root = "/run/current-system/webapps/${webappName}";
       vhostConf = ''
-        Alias /ttrss "${webRoot}"
-        <Directory "${webRoot}">
+        Alias /ttrss "${root}"
+        <Directory "${root}">
           DirectoryIndex index.php
           <FilesMatch "\.php$">
             SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"