]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/tools/ttrss.nix
Remove useless relative symlinks
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / ttrss.nix
index 9e6f98d4be435f3243dada8138660c710e72893c..1239b9dc5efba65e4094558b0ec2420629046380 100644 (file)
@@ -118,7 +118,7 @@ let
     webRoot = stdenv.mkDerivation (fetchedGit ./tt-rss.json // rec {
       buildPhase = ''
         rm -rf lock feed-icons cache
-        ln -sf ../../../../../${varDir}/{lock,feed-icons,cache} .
+        ln -sf ${varDir}/{lock,feed-icons,cache} .
       '';
       installPhase = ''
         cp -a . $out
@@ -128,13 +128,15 @@ let
         )}
       '';
     });
-    apache = {
+    apache = rec {
       user = "wwwrun";
       group = "wwwrun";
       modules = [ "proxy_fcgi" ];
+      webappName = "tools_ttrss";
+      root = "/run/current-system/webapps/${webappName}";
       vhostConf = ''
-        Alias /ttrss "${webRoot}"
-        <Directory "${webRoot}">
+        Alias /ttrss "${root}"
+        <Directory "${root}">
           DirectoryIndex index.php
           <FilesMatch "\.php$">
             SetHandler "proxy:unix:${phpFpm.socket}|fcgi://localhost"