]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/tools/shaarli.nix
Use standard packages and move bitlbee-mastodon to pkgs for bitlbee
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / shaarli.nix
index 543518152bd781096bd3d03ce2bde2af21c827eb..19b27c2528771a40506e5d9d7d6bae186cc1517e 100644 (file)
@@ -49,7 +49,7 @@ in rec {
     vhostConf = ''
       Alias /Shaarli "${root}"
 
-      Include /run/keys/webapps/tools-shaarli
+      Include /var/secrets/webapps/tools-shaarli
       <Directory "${root}">
         DirectoryIndex index.php index.htm index.html
         Options Indexes FollowSymLinks MultiViews Includes
@@ -61,11 +61,11 @@ in rec {
       </Directory>
       '';
   };
-  keys.tools-shaarli = {
-    destDir = "/run/keys/webapps";
+  keys = [{
+    dest = "webapps/tools-shaarli";
     user = apache.user;
     group = apache.group;
-    permissions = "0700";
+    permissions = "0400";
     text = ''
       SetEnv SHAARLI_LDAP_PASSWORD "${env.ldap.password}"
       SetEnv SHAARLI_LDAP_DN       "${env.ldap.dn}"
@@ -73,7 +73,7 @@ in rec {
       SetEnv SHAARLI_LDAP_BASE     "${env.ldap.base}"
       SetEnv SHAARLI_LDAP_FILTER   "${env.ldap.search}"
       '';
-  };
+  }];
   phpFpm = rec {
     serviceDeps = [ "openldap.service" ];
     basedir = builtins.concatStringsSep ":" [ webRoot varDir ];