]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/tools/roundcubemail.nix
Add skins for roundcube
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / roundcubemail.nix
index c0a1125835cfc72c6e5141862fa4b7a59cc95615..58a1be51e49ec254f892f41871fc303742515230 100644 (file)
@@ -1,7 +1,8 @@
-{ lib, env, writeText, stdenv, fetchurl }:
+{ lib, env, writeText, stdenv, fetchurl, fetchedGithub }:
 let
   roundcubemail = let
     plugins = {};
+    skins = {};
   in rec {
     varDir = "/var/lib/roundcubemail";
     activationScript = {
@@ -59,6 +60,9 @@ let
         ${builtins.concatStringsSep "\n" (
           lib.attrsets.mapAttrsToList (name: value: "ln -sf ${value} $out/plugins/${name}") plugins
         )}
+        ${builtins.concatStringsSep "\n" (
+          lib.attrsets.mapAttrsToList (name: value: "ln -sf ${value} $out/skins/${name}") skins
+        )}
       '';
     };
     apache = rec {
@@ -84,7 +88,8 @@ let
     phpFpm = rec {
       basedir = builtins.concatStringsSep ":" (
         [ webRoot config varDir ]
-        ++ lib.attrsets.mapAttrsToList (name: value: value) plugins);
+        ++ lib.attrsets.mapAttrsToList (name: value: value) plugins
+        ++ lib.attrsets.mapAttrsToList (name: value: value) skins);
       socket = "/var/run/phpfpm/roundcubemail.sock";
       pool = ''
         listen = ${socket}